POJ 1463 Strategic game(树形dp入门)

Strategic game

Bob enjoys playing computer games, especially strategic games, but
sometimes he cannot find the solution fast enough and then he is very
sad. Now he has the following problem. He must defend a medieval city,
the roads of which form a tree. He has to put the minimum number of
soldiers on the nodes so that they can observe all the edges. Can you
help him?

Your program should find the minimum number of soldiers that Bob has
to put for a given tree.

For example for the tree:
在这里插入图片描述
the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set
represents a tree with the following description:

the number of nodes the description of each node in the following
format node_identifier:(number_of_roads) node_identifier1
node_identifier2 … node_identifiernumber_of_roads or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n
nodes (0 < n <= 1500);the number_of_roads in each line of input will
no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given
input data set, print one integer number in a single line that gives
the result (the minimum number of soldiers). An example is given in
the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

题意:

告诉你所有节点的连接情况,如果一个节点放一个士兵的话,那么这么士兵可以看到这个节点以及和这个节点直接连接的节点,然后问你最少要放多少个士兵可以使得所有的节点都能被看到

思路:

需要用到树形dp,对于节点u,dp[u][0]表示这个节点不放士兵,dp[u][1]表示这个节点放士兵

  • 如果节点u不放士兵的话,那么节点v是要放士兵的,此时dp[u][0]+=dp[v1][1]
  • 如果节点u放士兵的话,节点v可放士兵也可以不放,此时转移方程就是 dp[u][1]+=min(dp[v1][0],dp[v1][1])
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <iostream>
using namespace std;
int n;
const int maxn=1505;
const int inf=0x3f3f3f3f;
vector<int>v[maxn];
int vis[maxn],dp[maxn][2];
void dfs(int u)
{
    dp[u][0]=0,dp[u][1]=1;
    for(int i=0;i<v[u].size();i++)
    {
        int v1=v[u][i];
        if(vis[v1])
        {
            continue;
        }
        vis[v1]=1;
        dfs(v1);
        dp[u][1]+=min(dp[v1][0],dp[v1][1]);
        dp[u][0]+=dp[v1][1];
    }
}
void init()
{
    memset(vis,0,sizeof(vis));
    for(int a=0;a<n;a++)
    {
        v[a].clear();
    }
    memset(dp,inf,sizeof(dp));
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        init();
        for(int a=1;a<=n;a++)
        {
            int x,y,m;
            scanf("%d:(%d)",&x,&m);
            for(int b=1;b<=m;b++)
            {
                scanf("%d",&y);
                v[x].push_back(y);
                v[y].push_back(x);
            }
        }
        vis[0]=1;
        dfs(0);
        printf("%d\n",min(dp[0][0],dp[0][1]));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值