POJ3020 Antenna Placement(二分图匹配 匈牙利算法)

Antenna Placement
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7044 Accepted: 3498

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space.

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

题目大意:

一个矩形中,有N个城市’*’,现在这n个城市都要覆盖无线,若放置一个基站,那么它至多可以覆盖相邻的两个城市。问至少放置多少个基站才能使得所有的城市都覆盖无线?

思路:

本题需要有转化的思维,我们可以把*和o离散化,把o用0表示,*用第几个点来表示,这样我们就得到了一个图,各个顶点就是数值,这样我们就可以开数组了,用邻接矩阵去存,可知构成的图是双向的,双向的图可以认为是无向图,所以例如顶点1和顶点2能连通,那么我们置map[1][2] = map[2][1] = true表示能通,然后我们需要知道二分图匹配的一个公式 : 最小路径覆盖 = |P| - 最大匹配数,这个公式适合有向图,无向图其实也很简单只要将最大匹配数/2即可,因为无向图我们多算了一倍的最大匹配数,最后我们可以得到本题的公式  无向图的最小路径覆盖 = |P| (顶点个数) - 最大匹配数 / 2。本题只要思路清楚,1A.

代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

const int maxn = 1000;
int result[maxn];
int map[maxn][maxn]; //离散化成点
bool con[maxn][maxn]; //i,j是否连通
bool visit[maxn];
int cnt;

bool dfs(int a)
{
    int i;
    for(i=1;i<=cnt;i++)
    {
        if(!visit[i] && con[a][i])
        {
            visit[i] = true;
            if(result[i] == 0 || dfs(result[i]))
            {
                result[i] = a;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int T;
    int m,n;
    char str;
    int i,j;
    int ans;
    //freopen("111","r",stdin);
    cin>>T;
    while(T--)
    {
        int res;
        ans = 0;
        memset(con,false,sizeof(con));
        memset(result,0,sizeof(result));
        cin>>m>>n;
        cnt = 0;
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                cin>>str;
                if(str == 'o')
                {
                    map[i][j] = 0;
                }
                else if(str == '*')
                {
                    map[i][j] = ++cnt;
                }
            }
        }
        /*
        行中列相邻
        */
        for(i=1;i<=m;i++)
        {
            for(j=1;j<n;j++)
            {
                int pos1 = map[i][j];
                int pos2 = map[i][j+1];
                if(pos1 && pos2)
                {
                    con[pos1][pos2] = true; //无向图连通
                    con[pos2][pos1] = true;
                }
            }
        }
        /*
        列中行相邻
        */
        for(i=1;i<=n;i++)
        {
            for(j=1;j<m;j++)
            {
                int pos1 = map[j][i];
                int pos2 = map[j+1][i];
                if(pos1 && pos2)
                {
                    con[pos1][pos2] = true;
                    con[pos2][pos1] = true;
                }
            }
        }
        /*for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                cout<<map[i][j];
            }
            cout<<endl;
        }*/
        for(i=1;i<=cnt;i++)
        {
            memset(visit,false,sizeof(visit));
            if(dfs(i))
            {
                ans++;
            }
        }
        res = cnt - ans / 2;
        cout<<res<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值