POJ2142 The Balance(扩展欧几里德)

The Balance
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 5016 Accepted: 2197

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1

题目大意:

用两种砝码,质量分别为m,n,数量不限,称出重量为重量为k的阿司匹林并要求两种砝码用的数量越小越好,如果有相同的解输出x+y小的那组.

解题思路:

很容易列出方程ax + by = d,很明显应该用扩展欧几里德去求根,求出x,y然后分成两组,求出x可以根据方程推出y,求出y可以根据方程推出x.然后取两组相加的最小值即可.


AC代码:
#include<iostream>

using namespace std;

long long gcd(long long a,long long b)
{
	if(b == 0)
	{
		return a;
	}
	return gcd(b,a % b);
}

void extend_gcd(long long a,long long b,long long &x,long long &y)
{
	if(b == 1)
	{
		x = 1;
		y = 1 - a;
	}
	else
	{
		long long x1,y1;
		extend_gcd(b,a % b,x1,y1);
		x = y1;
		y = x1 - x * (a / b);
	}
}

int main()
{
	long long m,n,k;
	while(cin>>m>>n>>k && m + n + k)
	{
		long long g = gcd(m,n);
		long long x,y;
		long long vy,vx;
		m /= g;
		n /= g;
		extend_gcd(m,n,x,y);
		vx = x * k / g; //求出x的解,然后根据方程推y 
		vx = (vx % n + n) % n;
		vy = (k / g - m * vx) / n;
		if(vy < 0) vy = -vy;
		
		y = y * k / g; //求出y的解,然后根据方程推x 
		y = (y % m + m) % m;
		x = (k / g - n * y) / m;
		if(x < 0) x = -x;
		if(x + y > vx + vy) //最后比较那组更优 
		{
			x = vx;
			y = vy;
		}
		cout<<x<<" "<<y<<endl;
	}
	return 0;	
} 



  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值