poj1014 Dividing(递归,多重背包)

Dividing

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 62888 Accepted: 16287

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

解题思路:

本题可以利用多重背包解题,不过看了某大牛的解题报告,发现也可以用递归来解,也顺便写了一下递归,递归用好真的可以很暴力,首先我们先把总和求出来,然后分成两份,总和是奇数那就意味着不能平均分配,因为只能取整数,所以只要是总和是奇数我们就可以马上输出结果不能平均分配,如果是偶数我们再判断,我们先把总和分成两份,然后利用递归求解,我们不断取物品,从头开始选取也行,从后面开始选取也行,由于从后面取由于数额比较大,更次通过更少次选取达到所需要的目标,所以我们从后面(序号6开始选取物品),如果刚好等于总和的一半我们返回真,如果不能刚好等于总和的一半我们继续递归。

AC代码:

#include<iostream>
using namespace std;

int a[7];
int m,n,p,q,r,s;
bool flag;
bool dfs(int half,int curtotal,int num) //half为递归终止条件,curtotal为当前物品总价值,num为当前遍历到的序列号 
{
	int i;
	if(flag == true)
	{
		return flag;
	}
	if(curtotal == half)
	{
		flag = true;
		return flag;
	}
	else
	{
		for(i=num;i>=1;i--)  //从后往前递归 
		{
			if(a[i]) //如果序号i的物品还有剩 
			{
				if(curtotal + i <= half) //如果还不足half,那就一直加 
				{
					a[i]--; //物品数-1 
					dfs(half,curtotal + i,i); //继续递归
					
					if(flag) 
						break;
				}
			}
		}
	}
	return flag;
}

int main()
{
	int i;
	int sum;
	int cnt = 1;
	int halfcnt;
	while(cin>>m>>n>>p>>q>>r>>s && m + n + p + q + r + s)
	{
		sum = 0;
		a[1] = m;
		a[2] = n;
		a[3] = p;
		a[4] = q;
		a[5] = r;
		a[6] = s;
		cout<<"Collection #"<<cnt++<<":"<<endl;
		for(i=1;i<=6;i++)
		{
			sum += i * a[i];
		}
		if(sum % 2)
		{
			cout<<"Can't be divided."<<endl;
			cout<<endl;
			continue;
		}
		else
		{
			halfcnt = sum / 2;
		}
		flag = false;
		bool success = dfs(halfcnt,0,6);
		if(success)
		{
			cout<<"Can be divided."<<endl;
			cout<<endl;
			continue;
		}
		else
		{
			cout<<"Can't be divided."<<endl;
			cout<<endl;
			continue;
		}
	}
	return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值