POJ2478 Farey Sequence(欧拉函数,打表)

Farey Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13435 Accepted: 5272

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

题目大意:

法雷级数Fn(n >= 2)由一系列不能约分的分数a/b(0 < a < b  <= n 且gcd(a,b) =1)按递增的顺序排列组成,下面是法雷级数的前几项:

F2 = {1/2}
F3 = {1/3,1/2,2/3}
F4 = {1/4,1/3,1/2,2/3,3/4}
F5 = {1/5,1/4,1/3,2/5,1/2,3/5,2/3,3/4,4/5}

解题思路:

一个法雷序列Fn中数的个数就是分别与2,3,4,5,....,n-1,n互素的数的个数和,继而就是求从2到n连续的欧拉函数值的和,因为N的范围是[2,1000000],可以直接用欧拉函数的递推方法来求解,再打表预处理前n项和即可。


AC代码:

#include<iostream>
#include<cstdio>
using namespace std;

const int maxn = 1000001;
long long phi[maxn];

void dabiao()
{
	int i,j;
	for(i=1;i<=maxn;i++)
		phi[i] = i;
	for(i=2;i<=maxn;i+=2)
		phi[i] /= 2;
	for(i=3;i<=maxn;i+=2)
		if(phi[i] == i)
		{
			for(j=i;j<=maxn;j+=i)
			{
				phi[j] = phi[j] / i * (i-1);
			}
		}
	for(i=3;i<=1000001;i++)
	{
		phi[i] += phi[i-1]; 
	}
}

int main()
{
	int m;
	dabiao();
	while(scanf("%d",&m) != EOF && m)
	{
		printf("%lld\n",phi[m]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值