POJ1364 King(差分约束 SPFA)

King
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11146 Accepted: 4081

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence. 

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions. 

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong. 

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions. 

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not. 

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

题目大意:

一个国王通过一个序列来做决定,他会有这个序列的一段连续子序列,并且知道这段子序列的和是大于或者小于某个数,问这样的序列是否存在,实际上就是求一组不等式是否有解,这些不等式要么是Xa + Xa+1 ... + Xb < k 或者是Xa + Xa+1 ... + Xb > k.


解题思路:

Xa + Xa+1 ... + Xb < k可以转化为Tb - Ta-1 < k(其中Tb为X1+X2...+Xb),Xa + Xa+1 ... + Xb > k可以转化为Tb - Ta-1 > k即Ta-1 - Tb < -k,因为差分约束要求<=,而且这些数都为整数所以又可以转化为Tb - Ta-1 <= k - 1和Ta-1 - Tb <= -k - 1,接下来构图,调用SPFA模版,然后记得判定负环.还有本题因为可能构图后不连通,所以要加一个超级源点和每个点连通,距离设为0.


AC代码:

#include<iostream>
#include<cstring>
#include<cstdio> 
using namespace std;

const int maxn = 1001;
const int inf = 0x3f3f3f3f;
int sum[maxn];
int head[maxn];
int dist[maxn];
int Min;

struct Edge
{
	int to;
	int next;
	int w;	
}edge[maxn * 3];

int cnt;

void init()
{
	cnt = 0;
	Min = inf;
	memset(head,-1,sizeof(head));	
	memset(sum,0,sizeof(sum));
};

void addEdge(int u,int v,int w)
{
	edge[cnt].to = v;
	edge[cnt].w = w;
	edge[cnt].next = head[u];
	head[u] = cnt++;
}

bool SPFA(int s,int n)
{
	int i,k;
	bool vis[maxn];
	int outque[maxn];
	int queue[maxn];
	int iq;
	int top;
	for(i=0;i<=n;i++)
	{
		dist[i] = inf;
	}
	memset(vis,false,sizeof(vis));
	memset(outque,0,sizeof(outque));
	iq = 0;
	queue[iq++] = s;
	vis[s] = true;
	dist[s] = 0;
	i = 0;
	while(i != iq)
	{
		top = queue[i];
		vis[top] = false;
		outque[top]++;
		if(outque[top] > n) return false; //有负环 
		k = head[top];
		while(k >= 0)
		{
			if(dist[edge[k].to] - edge[k].w > dist[top])
			{
				dist[edge[k].to] = dist[top] + edge[k].w;
				if(dist[edge[k].to] < Min)
				{
					Min = dist[edge[k].to];
					//cout<<Min<<endl;
				}
				if(!vis[edge[k].to])
				{
					vis[edge[k].to] = true;
					queue[iq] = edge[k].to;
					iq++;
				}
			}
			k = edge[k].next;
		}
		i++;
	}
	return true;
}


int main()
{
	int m,n;
	int i;
	char str[4];
	int index,con,goal;
	//freopen("1.txt","r",stdin);
	while(scanf("%d",&m) != EOF && m)
	{
		scanf("%d",&n);
		init();
		/*for(i=1;i<=m;i++)
		{
			sum[i] = sum[i-1] + i;
			//cout<<sum[i]<<endl;
		}*/
		for(i=1;i<=n;i++)
		{
			scanf("%d%d%s%d",&index,&con,str,&goal);
			if(str[0] == 'g') //大于的情况 ta-1 - tb <= -k - 1 ,起点tb,终点ta-1 
			{
				int res = index + con + 1;
				int res1 = index;
				int res2 = -goal - 1;
				addEdge(res,res1,res2);
			}
			else if(str[0] == 'l') //小于的情况tb - ta-1 <= k -1 
			{
				int res = index;
				int res1 = index + con + 1;
				int res2 = goal - 1;
				addEdge(res,res1,res2);
			}
		}
		for(i=1;i<=m+1;i++)
		{
			addEdge(0,i,0);
		}
		if(SPFA(0,m+1))
		{
			printf("lamentable kingdom\n");
		}
		else
		{
			printf("successful conspiracy\n");
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值