Light Bulb

Description

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.


Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.0000.7504.000

 

题解:求影子的最大长度,从大的方面来讲,可以分成三种情况,一种是影子全在地上,一种是影子一部分在地上,一部分在墙上,第三种是影子全在墙上。

设 人到灯源所在直线的距离为X,光线的延长线与地面的夹角为a,D由墙延伸出来与光线相交的距离为m。

当影子全在地上时,有X/(H-h) = D/H;

第二种情况下,tan a  = L/m = (H-h)/X;  L / H  =  m / (D+m);用含X的式子代替m,得出方程所以 shadow = D - X + L = D+H - 【X+ (H-h)*D / X】,关于X的函数求值最大,可以求导数,求出X的值,再代入方程,求结果。

第三种情况,就是人站在墙边,影长为身高。


#include <stdio.h>
#include <math.h>

int main()
{
    double H,h,D,x1,x2,x3;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf",&H,&h,&D);
        x1 = D*(H-h)/H;
        x2 = sqrt((H-h)*D);
        if(x2 > x1 && x2 < D)
            printf("%.3lf\n",D-x2+H-(H-h)*D/x2);
        else
        {
            x3 = h*D/H;
            if(x3 < h)
                printf("%.3lf\n",h);
            else
                printf("%.3lf\n",x3);
        }
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值