B - Light Bulb

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line.H is the height of the light bulb while h is the height of mildleopard.D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, andH - h >= 10-2.

<b< dd="">

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

<b< dd="">

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

<b< dd="">

Sample Output

1.000
0.750
4.000 
火柴人从灯泡下向D前进,影子开始会慢慢变长,而当影子的落点到达D时,如果继续向D前进,影子也许会继续变长,也许会变短,所以火柴人前进的距离与影子的长度的函数是个开口向下的凸函数(当有凹凸时可以试试三分),因此比较适合三分法
#include <stdio.h>
#include <iostream>
#include <math.h>
using namespace std;
int main()
{

    int T;
    //freopen("1.txt","r",stdin);
    scanf("%d",&T);
    while (T--)
    {
        double H,h,D,t1,t2,l,r,mid,midd;
        scanf("%lf%lf%lf",&H,&h,&D);
        l=(H - h) * D / H,r=D;
        while(r-l>=1e-8)
        {
            mid=(r+l)/2,midd=(mid+r)/2;
            t1=D - mid + H - (H - h) * D / mid;
            t2=D - midd + H - (H - h) * D / midd;

            if(t1<t2)l=mid;
            else r=midd;
        }
        printf("%.3lf\n",t2);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值