Broken Keyboard SDUTOJ

题目描述

Bruce Force\'s keyboard is broken, only a few keys are still working. Bruce has figured out he can still type texts by switching the keyboard layout whenever he needs to type a letter which is currently not mapped to any of the m working keys of the keyboard.

You are given a text that Bruce wishes to type, and he asks you if you can tell him the maximum number of consecutive characters in the text which can be typed without having to switch the keyboard layout. For simplicity, we assume that each key of the keyboard will be mapped to exactly one character, and it is not possible to type other characters by combination of different keys. This means that Bruce wants to know the length of the largest substring of the text which consists of at most m different characters.

输入

The input contains several test cases, each test case consisting of two lines. The first line of each test case contains the number m (1 ≤ m ≤ 128), which specifies how many keys on the keyboard are still working. The second line of each test case contains the text which Bruce wants to type. You may assume that the length of this text does not exceed 1 million characters. Note that the input may contain space characters, which should be handled like any other character.

The last test case is followed by a line containing one zero.

输出

 

示例输入

5
This can\'t be solved by brute force.
1
Mississippi
0

示例输出

7
2

提示

Hint: The largest substring for the first test case is "_by_bru", where _ stands for a space character.

题意:
给定几个字符的数目,一个字符串,求这个字符串中连续出现n个字符的最长子串长度

从头到尾遍历,借助标记法,不需要回溯

#include <stdio.h>
#include <string.h>

char mapp[1000009];
int bj[1000];
int main()
{
    int n,len,left,right,slong,n1,m_long;
    while(~scanf("%d",&n),n)
    {
        getchar();
        gets(mapp);
        memset(bj,0,sizeof(bj));
        len = strlen(mapp);
        left = right = slong = n1 = m_long = 0;
        while(left <= right && right < len)
        {
            while(n1 <= n && right < len)//子串中不同字符的个数不能超过规定的字符数
            {
                if(bj[mapp[right]] == 0)//该字符没有出现过
                {
                    bj[mapp[right]] = 1;//标记为已出现
                    n1++;//字符种类数增加
                    if(n1 > n)
                        break;
                }
                else
                    bj[mapp[right]]++;
                right++;
                slong++;//子串长度增加
            }
            if(slong > m_long)
                m_long = slong;
            if(right >= len)
                break;
            while(1)//实现左区间向前移
            {
                //如果作为左端点的字符出现过的次数不是一次,则肯定不会是最长的字符串,所以无需遍历
                bj[mapp[left]]--;
                if(bj[mapp[left]] == 0)
                    break;
                left++;
                slong--;
            }
            left++;
            n1--;
            right++;

        }
        printf("%d\n",m_long);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值