Broken Keyboard(hash)

Broken Keyboard

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 691    Accepted Submission(s): 274


Problem Description
Bruce Force's keyboard is broken, only a few keys are still working. Bruce has figured out he can still type texts by switching the keyboard layout whenever he needs to type a letter which is currently not mapped to any of the m working keys of the keyboard. 

You are given a text that Bruce wishes to type, and he asks you if you can tell him the maximum number of consecutive characters in the text which can be typed without having to switch the keyboard layout. For simplicity, we assume that each key of the keyboard will be mapped to exactly one character, and it is not possible to type other characters by combination of different keys. This means that Bruce wants to know the length of the largest substring of the text which consists of at most m different characters. 

 

Input
The input contains several test cases, each test case consisting of two lines. The first line of each test case contains the number m (1 ≤ m ≤ 128), which specifies how many keys on the keyboard are still working. The second line of each test case contains the text which Bruce wants to type. You may assume that the length of this text does not exceed 1 million characters. Note that the input may contain space characters, which should be handled like any other character. 

The last test case is followed by a line containing one zero. 

 

Output
For each test case, print one line with the length of the largest substring of the text which consists of at most m different characters.
 

Sample Input
  
  
5 This can't be solved by brute force. 1 Mississippi 0
 

Sample Output
  
  
7 2
Hint
The largest substring for the first test case is "_by_bru", where _ stands for a space character.
 

Source
 

题意很简单就是让你用·n个不同的字符组成的最大字符串的长度!

#include <iostream>
#include<cstring>
using namespace std;
char key[1100000];
long hash1[256];
int main()
{
    long n,num,p;
    while (scanf("%ld",&n)!=EOF&&n)
    {
        getchar();
        gets(key);
        memset(hash1,0,sizeof(hash1));
        long i,start;
        long diff=0;
        long res=0;
        for (start=i=0;key[i]!='\0';++i)
        {
            ++hash1[key[i]];//映射值+
            if (hash1[key[i]]==1)//如果是第一次出现
            {
                ++diff;//不同字母数+1
                if (diff>n)//如果超过n个不同字母
                {
                   /* c=key[start];
                    while(key[start]==c)
                    {
                        hash[c]--;
                        start++;
                    }
                    比如:aabacdefg n=3
                    最大是5当程序运行到d的时候如何消掉a呢?我用上面那个方法发现消不掉a因为中间隔了一个b
                    那样的话diff不会减一!
                    别人的想法是把b消掉,就是这样做的!
                    上面这个有问题的,我当时的意思是*/
                    /*while(hash[key[start]]>0)
                    {
                        hash[key[start]]--;
                        start++;
                    }
                    上面这个也不对,为什么呢?
                    比如abcde n=4我只是想消掉a但是你会发现都消完了,所以上面那个不对!*/
                    do
                    {
                        hash1[key[start]]--;
                        start++;
                    }while(hash1[key[start-1]]>0);//这一点需要判断一下前面那个是否为0!
                   diff--;
                }
            }
            long len=i-start+1;//得到此时的串长度
            res=res>len?res:len;//保存最大值
        }
        printf("%ld\n",res);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值