UVA 10341 (二分查找+精度)

题意:

给你一个关于x的方程,给出变量的值,求出x;


Problem F

Solve It

Input:standard input

Output:standard output

Time Limit: 1 second

Memory Limit: 32 MB

Solve the equation:
        p*e-x+ q*sin(x) + r*cos(x) +s*tan(x) +t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line:p,q,r, s,t and u (where0 <= p,r <= 20 and-20 <=q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value ofx, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
思路:
二分法零点定理找根,必须在[0,1]上单调,求导f'(x)=-p*e(-x)+q*cos(x)-r*sin(x)+s/(cos(x)*cos(x))+2t*x
x      , [0,1]
e(-x) ,[1/e,1]
cos(x),[0,pi]
sin(x) , [0,pi]
p,r>0 q,s,t<0, f'(x)的每一项都是负的,
f(x)单调递减,故二分枚举,当f(left) *f(right)>0,无解

代码:

#include <iostream>// 二分查找,
#include <algorithm>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
typedef long long ll;
typedef pair<int,int> P;
const int maxn=105;
const int base=1000;
const int inf=0x3f3f3f3f;
const double eps=1e-8;
const double pi=acos(-1.0);
double p,q,r,s,t,u;
double fun(double x)
{
    return p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*pow(x,2)+u;
}
int main()
{
    int n,m,i,j;
    while(~scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u))
    {
        int sum=0;
        double left=0, right=1, mid;
        bool flag=false;
        if(fun(left)*fun(right)>0)  //在同一侧,无解
        {
            printf("No solution\n");
            continue;
        } 
        while(right-left>eps)      //二分逼近
        {
            mid=(left+right)/2;
            if(fun(mid)*fun(left)>0) left=mid;
            else right=mid;
        }
        printf("%.4f\n",mid);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值