POJ 3368 Frequent values (RMQ)

http://poj.org/problem?id=3368
Frequent values
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 13897Accepted: 5093

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

Source

题意是:求区间内出现频率最高的那个数字的频数;
很好的一道题目。相同的进行合并然后分情况讨论。具体看代码

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<stdlib.h>
#include<iomanip>
#include<list>
#include<deque>
#include<map>
#include <stdio.h>
#include <queue>
#include <stack>
#define maxn 100005
#define ull unsigned long long
#define ll long long
#define reP(i,n) for(i=1;i<=n;i++)
#define rep(i,n) for(i=0;i<n;i++)
#define cle(a) memset(a,0,sizeof(a))
#define mod 90001
#define PI 3.141592657
#define INF 1<<30
const ull inf = 1LL << 61;
const double eps=1e-5;

using namespace std;
struct node
{
int s,e;
}line[maxn];

int dp[maxn][20];
int a[maxn];
int pos[maxn];

void rmq_init(int n)
{
for(int i=0;i<n;i++)
dp[i][0]=line[i+1].e-line[i+1].s+1;
for(int j=1;(1<<j)<=n;j++)
for(int i=0;i+(1<<j)-1<n;i++)
dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
}
int rmq(int l,int r)
{
int k=0;
while((1<<(k+1))<=r-l+1)k++;
return max(dp[l][k],dp[r-(1<<k)+1][k]);
}
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int t,m;a[0]=INF;
while(~scanf("%d",&t)&&t)
{
scanf("%d",&m);
int num=0;//线段的数量
for(int i=1;i<=t;i++)
{
scanf("%d",&a[i]);
if(a[i]!=a[i-1])
{
num++;
pos[i]=num;
line[num].e=line[num].s=i;
}
else
{
pos[i]=num;
line[num].e++;
}
}
int x,y;rmq_init(num);
for(int i=1;i<=m;i++)
{
scanf("%d%d",&x,&y);
if(pos[x]==pos[y])//在一个区间
{
printf("%d\n",y-x+1);
}
else if(pos[y]-pos[x]==1)//相邻
{
printf("%d\n",max(y-line[pos[y]].s+1,line[pos[x]].e-x+1));
}
else if(pos[y]-pos[x]!=1)
{
int p=max(y-line[pos[y]].s+1,line[pos[x]].e-x+1);
int q=rmq(pos[x]+1-1,pos[y]-1-1);
printf("%d\n",max(p,q));
}
}
}
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值