POJ 1753

10 篇文章 0 订阅
Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 29060 Accepted: 12569

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source


题意 翻黑白棋,每次翻棋都需要讲上下左右的四个旗子一起反面,当棋盘上全部为白棋或者黑棋的时候结束,求最小步数;

这道题有BFS DFS 数学三种做法, BFS与 DFS做法已出炉,数学法正在推导。
BFS
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <ctype.h>
#include <iostream>
#include <algorithm>
#include <map>
#include <string>
#include <vector>

using namespace std;

int Map[4][4];

struct node
{
    int New[17];//新的地图
    int x;//当前位置
    int ans;//步数
} status[1000001];

int Final(node a)//判断是否为结束
{
    int sum=0;
    for(int i=0; i<16; i++)
        sum+=a.New[i];
    return sum;
}

/*void turn(int i,node a)
{
    if(i-4>=0)
        a.New[i-4]=1-a.New[i-4];
    if(i%4)
        a.New[i-1]=1-a.New[i-1];
    if(i+4<=15)
        a.New[i+4]=1-a.New[i+4];
    if((i+1)%4)
        a.New[i+1]=1-a.New[i+1];
    a.New[i]=1-a.New[i];
}*/

void bfs()
{
    for(int i=0; i<4; i++)
        for(int j=0; j<4; j++)
            status[0].New[i*4+j]=Map[i][j];
    status[0].x=0;
    status[0].ans=0;
    int s=1,e=0;
    while(s>e)
    {
        node f1,f2;
        f1=status[e++];
        int flag=Final(f1);
        if(flag==16||flag==0)
        {
            cout<<f1.ans<<endl;
            return ;
        }
        for(int i=0; i<16; i++)
        {
            if(f1.x<=i)
            {
                f2=f1;
                if(i-4>=0)
                    f2.New[i-4]=1-f2.New[i-4];//上
                if(i%4)
                    f2.New[i-1]=1-f2.New[i-1];//左
                if(i+4<=15)
                    f2.New[i+4]=1-f2.New[i+4];//下
                if((i+1)%4)
                    f2.New[i+1]=1-f2.New[i+1];//右
                f2.New[i]=1-f2.New[i];
                f2.ans=f1.ans+1;
                f2.x=i+1;
                status[s++]=f2;
            }
        }
    }
    cout<<"Impossible"<<endl;
    return ;
}

int main()
{
    char a[4];
    for(int i=0; i<4; i++)
    {
        cin>>a;
        for(int j=0; j<4; j++)
        {
            if(a[j]=='b')
                Map[i][j]=0;
            else
                Map[i][j]=1;
        }
    }
    bfs();
    return 0;
}

DFS
这段代码是俩月之前写的,自己都不太认识了。
c是用来标记步数的,如果大于32步就证明无解。
#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

int Map[5][5],c=33;

int flag()
{
    int sum=0,i,j;
    for(i=0; i<4; i++)
        for(j=0; j<4; j++)
            sum+=Map[i][j];
    if(sum%16==0)
        return 1;
    else
        return 0;
}

void Turn(int i,int j)//翻牌
{
    if(i>=0&&i<4&&j>=0&&j<4)
        Map[i][j]=!Map[i][j];
}

void fan(int a)
{
    int i=a/4;
    int j=a%4;
    Turn(i,j);//当前
    Turn(i+1,j);//下
    Turn(i,j+1);//右
    Turn(i-1,j);//上
    Turn(i,j-1);//左
}

void dfs(int a,int b)
{
    if(flag())
    {
        if(c>b)
            c=b;
        //printf("b %d\n",b);
        return;
    }
    if(a>16)
        return;
    dfs(a+1,b);
    fan(a);
    dfs(a+1,b+1);
    fan(a);
}

int main()
{
    char ch[4];
    int i,j;
    memset(Map,0,sizeof(Map));
    c=33;
    for(i=0; i<4; i++)
    {
        scanf("%s",ch);
        //puts(ch);
        for(j=0; j<4; j++)
            if(ch[j]=='w')
                Map[i][j]=1;
            else
                Map[i][j]=0;
    }
    dfs(0,0);
    if(c==33)
        printf("Impossible\n");
    else
        printf("%d\n",c);
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值