POJ 2632 Crashing Robots

4 篇文章 0 订阅
Crashing Robots
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7374 Accepted: 3232

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 
 
Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential order. 
An instruction has the following format: 
< robot #> < action> < repeat> 
Where is one of 
  • L: turn left 90 degrees, 
  • R: turn right 90 degrees, or 
  • F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case: 
  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

Source


模拟 没什么好说的 手残多次 有种想要剁手的冲动

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <ctype.h>
#include<algorithm>

using namespace std;

int Map[101][101],flag;
int move[4][2]= {{0,-1},{1,0},{0,1},{-1,0}};
int A,B;
char answer[100];

struct robot
{
    int x,y;
    int d;
} r[101];

void dir(int i,char c)
{
    if(c=='S') r[i].d=0;
    if(c=='E') r[i].d=1;
    if(c=='N') r[i].d=2;
    if(c=='W') r[i].d=3;
}

void Move(int no, int times)
{
    int d = r[no].d;
    Map[r[no].x][r[no].y]=0;
    for(int i=0; i<times; i++)
    {
        r[no].x += move[d][0];
        r[no].y += move[d][1];
        if((!r[no].x||r[no].x>A) || (!r[no].y||r[no].y>B))
        {
            flag=0;
            sprintf(answer,"Robot %d crashes into the wall\n", no);
            return ;
        }
        if(Map[r[no].x][r[no].y]!=0)
        {
            flag=0;
            sprintf(answer,"Robot %d crashes into robot %d\n", no, Map[r[no].x][r[no].y]);
            return ;
        }
    }
    Map[r[no].x][r[no].y] = no;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(answer,0,sizeof(answer));
        flag=1;
        memset(Map,0,sizeof(Map));
        char c;
        int n,m,i,j,no,d;
        scanf("%d %d",&A,&B);
        scanf("%d %d",&n,&m);
        for(i=1; i<=n; i++)
        {
            scanf("%d %d %c",&r[i].x,&r[i].y,&c);
            dir(i,c);
            Map[r[i].x][r[i].y]=i;
        }
        for(i=0; i<m; i++)
        {
            scanf("%d %c %d",&no,&c,&d);
            if(c=='F'&&flag)
                Move(no,d);
            else if(c=='L'&&flag)
            {
                d%=4;
                r[no].d=(r[no].d+d)%4;
            }
            else if(c=='R'&&flag)
            {
                d%=4;
                r[no].d=(r[no].d-d)%4;
                if(r[no].d<0)
                    r[no].d+=4;
            }
        }
        if(flag)
            printf("OK\n");
        else
            printf("%s",answer);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值