Number Sequence

</pre>Time Limit: 1000MS Memory l</h4><h2>题目描述</h2><div class="pro_desc">A number sequence is defined as follows: f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. Given A, B, and n, you are to calculate the value of f(n).</div><h2>输入</h2><div class="pro_desc">The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.</div><h2>输出</h2><div class="pro_desc">For each test case, print the value of f(n) on a single line.</div><h2>示例输入</h2><div class="data"><pre code_snippet_id="181787" snippet_file_name="blog_20140210_1_9786360">1 1 3
1 2 10
0 0 0

示例输出

2
5
#include<stdio.h>
int f[100000000];
int main()
{
	int i,x,a,b,n,e;
    while(scanf("%d %d %d",&a,&b,&n),a||b||n)
	{
		x=100000001;
      f[1]=1;
	  f[2]=1;
    	for(i=3;i<=n;i++)
		{
			f[i]=(a*f[i-1]+b*f[i-2])%7;
			if(f[i]==1&&f[i-1]==1)
			{
				x=i-2;
				break;
			}
		}
        e=n%x;
		printf("%d\n",f[e]);
	}
	return 0;
}

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

  
  

Description

A number sequence is defined as follows: f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. Given A, B, and n, you are to calculate the value of f(n).
 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output

For each test case, print the value of f(n) on a single line.
 

Sample Input

      
      
1 1 3 1 2 10 0 0 0
 

Sample Output

      
      
2 5
#include<stdio.h>
int f[60];
int main()
{
    int a,b,n;
    f[1]=1;
    f[2]=1;
    while(scanf("%d %d %d",&a,&b,&n)!=EOF&&a&&b&&n)
    {
        int i;
        for(i=3;i<=50;i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
        }
        n=n%49;
        printf("%d\n",f[n]);
    }
}

注意这两道题的memory不一样,第二道我做错了好几遍都是开的数组太大,其实这道题有规律可以优化
对于公式 f[n] = A * f[n-1] + B * f[n-2]; 后者只有7 * 7 = 49 种可能,为什么这么说,因为对于f[n-1] 或者 f[n-2] 的取值只有 0,1,2,3,4,5,6 这7个数,A,B又是固定的,所以就只有49种可能值了。由该关系式得知每一项只与前两项发生关系,所以当连续的两项在前面出现过循环节出现了,注意循环节并不一定会是开始的 1,1 。 又因为一组测试数据中f[n]只有49中可能的答案,最坏的情况是所有的情况都遇到了,那么那也会在50次运算中产生循环节。找到循环节后,就可以轻松解决了
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值