KMP训练~Number Sequence~解题报告

Number Sequence

题目描述:

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input:

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].

Output:

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input:

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output:

6
-1

题目大意:

给出测试样例数目,每一个测试样例给出了一个文本串以及模式串,问模式串与文本串匹配的开始位置在哪里。

思路分析:

这道题是典型的Kmp算法运用,直接套模板就行了,这里想了解Kmp算法自行查把,这个太复杂,不做解释。

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<map>
#include<vector>
#include<list>
#include<queue>
#include<stack>
#include<string>
#include<cstring>
#include<cmath>
#include<set>
#define fo(i,a,b) for( int i=(a); i<(b); ++i)
using namespace std;
int num3[1000000];
void LemonGetNext(int s1[],int num)
{
	num3[0]=-1;
	int k=-1;
	int j=0;
	while(j<num-1)
	{
		if(k==-1 || s1[j]==s1[k])
		{
			k++;
			j++;
			if(s1[j]!=s1[k])
			{
				num3[j]=k;
			}
			else
			{
				num3[j]=num3[k];
			}
		}
		else
		{
			k=num3[k];
		}
	}
}
int LemonSource(int s1[],int s2[],int num1,int num2)
{
	int i=0;
	int j=0;
	while(i<num1 && j<num2)
	{
		if(j==-1 || s1[i]==s2[j])
		{
			i++;
			j++;
			
		}
		else
		{
			j=num3[j];
		}
	}
	if(j==num2)
	{
		return i-j+1;
	}
	else
	return -1;
}
int main()
{
	int sum1[1000000];
	int sum2[10000];
	int b,h,g;
	cin >> b;
	fo(i,0,b)
	{
		int ans;
		cin >> h >> g;
		fo(j,0,h)
		cin >> sum1[j];
		fo(k,0,g)
		cin >> sum2[k];
		LemonGetNext(sum2,g);
		ans=LemonSource(sum1,sum2,h,g);
		cout << ans << endl;
	}
	
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值