poj1423 hdu1018 Big Number

Big Number
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25225 Accepted: 8079

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19
在杭电上交过了但是poj上便tle了
#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{
    int i,n,m;
   double s;
  scanf("%d",&n);
  while(n--)
  {
      s=0;
      scanf("%d",&m);
      for(i=1;i<=m;i++)
        s+=log10((double)i);
        printf("%d\n",(int)s+1);
  }
  return 0;
}

下面这个在杭电和poj上全过了
斯特林公式
#include<stdio.h>
#include<math.h>
#define  e 2.718281828459045
#define pi 3.1415926
int main()
{
    int m,n,l;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
        printf("%d\n",(int)(0.5*log10(2*pi*m)+m*log10(m/e))+1);
    }
    return 0;
}

被坑了好多次,这道题开始以为大数题目后拉总是错误于是就上网看了一下别人的代码发现有特殊做法便是用斯特林公式
但是因为+1在括号内导致当m=1时答案是0wa了好多次......
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值