UVA 264 Count on Canton 找规律

Description

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below. 
1/1 1/2 1/3 1/4 1/5 ...

2/1 2/2 2/3 2/4 
3/1 3/2 3/3 
4/1 4/2 
5/1 

In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

Input

The input list contains a single number per line and will be terminated by endof-file.

Output

You are to write a program that will read a list of numbers in the range from 1 to 10^7 and will print for each number the corresponding term in Cantor's enumeration as given below.

Sample Input

3
14
7

Sample Output

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4
#include<stdio.h>
#include<string.h>
int main()
{
    int n,m;
    int s,i,k,s1,t;
    while(~scanf("%d",&s))
    {
        for(k=1;k<=100000;k++)
        {
            s1=(k+k*k)/2;
            if(s1>=s)
                {
                    t=s1-s;
                    break;
                }
        }
        if(k%2)
        {
            m=t+1;
            n=k-t;
        }
        else
        {
            m=k-t;
            n=t+1;
        }
        printf("TERM %d IS %d/%d\n",s,m,n);
    }
    return 0;
}

这道题目是找规律的题目我看出来的规律是
每一条道路他的上下坐标是不同的因为是蛇形走法所以要分奇偶
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值