hdu 3032 Nim or not Nim? 博弈

题目大意:

Alice和Bob轮流取N堆石子,每堆S[i]个,Alice先,每一次可以从任意一堆中拿走任意个石子,也可以将一堆石子分为两个小堆。先拿完者获胜。(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)


做到这道题目我想到了以前的一道题目和尼姆博弈尼姆博弈--------->>>>点击打开链接(以前的题目)


可以看到S[i]的值可能非常大,如果计算每一堆的sg值是不现实的,所以需要我们找规律来计算给定的石堆的sg值。

找了半天规律,但是WA了,说明规律不对。

此题为博弈中的—取走-分割游戏(这种游戏允许取走某些东西,然后将原来的一个游戏分成若干个相同的游戏)

例1:Lasker's Nim游戏:每一轮允许两会中操作之一:①、从一堆石子中取走任意多个,②、将一堆数量不少于2的石子分成都不为空的两堆。

分析:很明显:sg(0) = 0,sg(1) = 1。

下面括号里面的是可以分得情况,相当于分成两个游戏进行异或即可

状态2的后继有:0,1和(1,1),他们的SG值分别为0,1,0,所以sg(2) =2。

状态3的后继有:0、1、2、(1,2),他们的SG值分别为0、1、2、3,所以sg(3) = 4。

状态4的后继有:0、1、2、3、(1,3)和(2,2),他们的SG值分别为0,1,2,4,5,0,所以sg(4) = 3.

再推一些,推测得到:对于所有的k >= 0,有 sg( 4k+1 ) = 4k+1; sg( 4k+2 ) = 4k+2; sg( 4k+3 ) = 4k+4; sg( 4k+4 ) = 4k+3。

假设游戏初始时有3堆,分别有2、5和7颗石子。三堆的SG函数值分别为2、5、8,他们的Nim和等于15.所以要走到P状态,就要使得第三堆的SG值变成7,可以将第三对按1和6分成两堆。

Description

Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap. 

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not. 

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
 

Input

Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
 

Output

For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
 

Sample Input

       
       
2 3 2 2 3 2 3 3
 

Sample Output

       
       
Alice Bob
 
其实很简单,但是前几天做题就做过一道sg函数的题目不太会,这次又参考了别人的才会的
sg打表:
/*#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
#define N 1000001
using namespace std;
int sg[N];
int g(int x)
{
    int mex[1000];
    memset(mex,0,sizeof(mex));
    if(sg[x]!=-1)  return sg[x];
    for(int i=x-1; i>=0; i--)
    {
        mex[g(i)]=1;
    }
    for(int i=1; i<=x/2; i++)
    {
        int ans=0;
        ans^=g(i);
        ans^=g(x-i);
        mex[ans]=1;
    }
    for(int i=0;; i++)
        if(!mex[i])  return sg[x]=i;
}
int main()
{
    int t , n ,x ;
    memset(sg,-1,sizeof(sg));
    sg[0]=0;
         g(100);
        for(int i=0; i<=100; i++)
        {
            cout<<sg[i]<<" ";
            if(i%10==0)
             printf("\n");
        }
        cout<<endl;
    return 0;
}*/
/*
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
#define LL long long
int sg[110000];//sg函数值打表代码
int getsg(int x)
{
    int ans, i;
    int mex[11000];
    memset(mex,0,sizeof(mex));
    for(i=x-1; i>=0; i--)//当选择拿出石子时的sg后继标记
    {
        mex[sg[i]]=1;
    }
    for(i=1; i<=x/2; i++)//当选择分成两堆时的sg后继标记
    {
        ans=0;
        ans^=sg[i];
        ans^=sg[x-i];
        mex[ans]=1;
    }
    for(i=0;; i++)//最小的非sg后继数
    {
        if(!mex[i])
        {
            sg[x]=i;
            return sg[x];
        }
    }
}
int main()
{
    int t, n, x, sum, i;
    sg[0]=0;

    for(i=0; i<100; i++)
    {
        getsg(i);
        printf("%d ",sg[i]);
        if(i%10==0)
            printf("\n");
    }
    return 0;
}
*/
AC代码:
#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
#define N 1000001
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int ans=0;
        for(int i=0; i<n; i++)
        {
            int a;
            scanf("%d",&a);
            if(a%4==0)
                ans^=(a-1);
            else if(a%4==1)
                ans^=a;
            else if(a%4==2)
                ans^=a;
            else
                ans^=a+1;
        }
        if(ans==0)
            printf("Bob\n");
        else
            printf("Alice\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值