poj 2096 Collecting Bugs 概率dp

题意:一个软件有s个子系统,会产生n种bug。 某人一天发现一个bug,这个bug属于某种bug,发生在某个子系统中。 求找到所有的n种bug,且每个子系统都找到bug,这样所要的天数的期望。
需要注意的是:bug的数量是无穷大的,所以发现一个bug,出现在某个子系统的概率是1/s,

属于某种类型的概率是1/n。

这道题目读题我读了好长时间加上又是第一次做概率dp实在是不会。。。。看了别人的



令 f[i][j] 表示已经找到了 i 种 bug,且 j 个子系统至少包含一个 bug,距离完成目标需要的时间的期望。

目标状态是 f[0][0]


再过一天找到一个 bug 可能是如下的情况:

        1. 这个 bug 的种类是 已经找到的 并且 出现在 已经找到 bug 的子系统中

        2. 这个 bug 的种类是 已经找到的 并且 出现在 没有找到 bug 的子系统中

        3. 这个 bug 的种类是 没有找到的 并且 出现在 已经找到 bug 的子系统中

        4. 这个 bug 的种类是 没有找到的 并且 出现在 没有找到 bug 的子系统中

 

经过简单的分析,不难得出如下递推过程:

        f[i][j] =    i/n*j/s*f[i][j]

                     + i/n*(s-j)/s*f[i][j+1]

                     + (n-i)/n*j/s*f[i+1][j]

                     + (n-i)/n*(s-j)/s*f[i+1][j+1]

 

移项可得

         (1-(i*j)/(n*s))f[i][j] =    i/n*(s-j)/s*f[i][j+1]

                                          + (n-i)/n*j/s*f[i+1][j]

                                          + (n-i)/n*(s-j)/s*f[i+1][j+1]

说一下自己的感悟吧,为什么要这样转换上面没换的就是错的呢?,因为如果不转换那么这次的是家了上次的里面的数量,为什么要+1,是因为这一分钟一定在这所以加上概率一具体解释可以看---->>> 点击打开链接

令 f[i][j] 表示已经找到了 i 种 bug,且 j 个子系统至少包含一个 bug,距离完成目标需要的时间的期望。

目标状态是 f[0][0]


再过一天找到一个 bug 可能是如下的情况:

        1. 这个 bug 的种类是 已经找到的 并且 出现在 已经找到 bug 的子系统中

        2. 这个 bug 的种类是 已经找到的 并且 出现在 没有找到 bug 的子系统中

        3. 这个 bug 的种类是 没有找到的 并且 出现在 已经找到 bug 的子系统中

        4. 这个 bug 的种类是 没有找到的 并且 出现在 没有找到 bug 的子系统中

 

经过简单的分析,不难得出如下递推过程:

        f[i][j] =    i/n*j/s*f[i][j]

                     + i/n*(s-j)/s*f[i][j+1]

                     + (n-i)/n*j/s*f[i+1][j]

                     + (n-i)/n*(s-j)/s*f[i+1][j+1]

 

移项可得

         (1-(i*j)/(n*s))f[i][j] =    i/n*(s-j)/s*f[i][j+1]

                                          + (n-i)/n*j/s*f[i+1][j]

                                          + (n-i)/n*(s-j)/s*f[i+1][j+1]


Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
double dp[1005][1005];
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        dp[n][m]=0;
        for(int i=n; i>=0; i--)
            for(int j=m; j>=0; j--)
            {
                if(i==n&&j==m)
                    continue;
                dp[i][j]=1.0*(n-i)*(m-j)/n/m*dp[i+1][j+1]+1.0*(n-i)*j/(n*m)*dp[i+1][j]+1.0*i*(m-j)/(n*m)*dp[i][j+1]+1;
                dp[i][j]/=(1.0-1.0*i*j/n/m);
            }
        printf("%.4lf\n",dp[0][0]);
    }
    return 0;
}

至于为什要加上一  ----->>>>点击打开链接

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值