hdu 1358 Period

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A  K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 
 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) �C the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 
 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 
 

Sample Input

       
       
3 aaa 12 aabaabaabaab 0
 

Sample Output

       
       
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 


解释一下题意:告诉你一个字符串,然后

Test case #2
2 2
6 2
9 3
12 4

第二行的2 2,意思是,从第1个字母到第2字母组成的字符串可由某一周期性的字串(“a”)

的两次组成,也就是aa有两个a组成;

第三行自然就是aabaab可有两个aab组成;

第四行aabaabaab可由三个aab组成;

第五行aabaabaabaab可有四个aab组成




对next数组还不是很理解的可以去next 数组深入理解看一下



另外说一下next[0]只是一个边界,防止越界和判断用,实际next[1]对应的才是数组的第一个。

#include<stdio.h>
#include<string.h>

using namespace std;
int next[1000002];
char b[1000002];
int n;
void getn(){
    int i,j;
    i=0;
    j=-1;
    next[0]=-1;
    int len=strlen(b);
    while(i<len){
        if(j==-1||b[i]==b[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
     }
}
int main(){
    int k=1;
   while(scanf("%d",&n)){
        if(n==0)
        break;
        memset(next,0,sizeof(next));
        memset(b,'0',sizeof(b));

      scanf("%s",b);

         getn();

    printf("Test case #%d\n",k++);
    int i;
    for(i=2;i<=n;i++){
        if(next[i]!=0&&i%(i-next[i])==0)
            printf("%d %d\n",i,i/(i-next[i]));
    }
      printf("\n");
   }
   return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值