HDU 5464Clarke and problem(DP)

21 篇文章 0 订阅
17 篇文章 0 订阅

Clarke and problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 289    Accepted Submission(s): 131


Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a student and read a book.
Suddenly, a difficult problem appears: 
You are given a sequence of number  a1,a2,...,an  and a number  p . Count the number of the way to choose some of number(choose none of them is also a solution) from the sequence that sum of the numbers is a multiple of  p ( 0  is also count as a multiple of  p ). Since the answer is very large, you only need to output the answer modulo  109+7
 

Input
The first line contains one integer  T(1T10)  - the number of test cases. 
T  test cases follow. 
The first line contains two positive integers  n,p(1n,p1000)  
The second line contains  n  integers  a1,a2,...an(|ai|109 ).
 

Output
For each testcase print a integer, the answer.
 

Sample Input
  
  
1 2 3 1 2
 

Sample Output
  
  
2 Hint: 2 choice: choose none and choose all.

简单DP题  求n个数中 m个数的和是p的倍数  m~(0-n)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

int dp[1010][1010];
int num[1010];
const int Mod=1e9+7;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,p;
        scanf("%d%d",&n,&p);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        int sum=1;
        for(int i=1;i<=n;i++)
        {
            num[i]%=p;
            if(num[i]<0) num[i]+=p;
            for(int j=0;j<p;j++) dp[i][j]=dp[i-1][j];
            dp[i][num[i]]=(dp[i][num[i]]+1)%Mod;
            for(int j=0;j<p;j++)
            {
                dp[i][(num[i]+j)%p]=(dp[i-1][j]+dp[i][(num[i]+j)%p])%Mod;
            }
        }
        printf("%d\n",dp[n][0]+1);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值