04-2. File Transfer (25)并查集

04-2. File Transfer (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2<=N<=104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:
no
no
yes
There are 2 components.
Sample Input 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:
no
no
yes
yes
The network is connected.

提交代


#include <iostream>  
#include <algorithm>  
#include <string>  
#include <cstdio>  
#include <cstring>  
#include <cstdlib>  
#include <cmath>  
#include <vector>  
#include<queue>  
#include<stack>  
#include<map>  
#include<set>  
using namespace std;  
#define lson rt<<1,l,MID  
#define rson rt<<1|1,MID+1,r  
//#define lson root<<1  
//#define rson root<<1|1  
#define MID ((l+r)>>1)  
typedef long long ll;  
typedef pair<int,int> P;  
const int maxn=50005;  
const int base=1000;  
const int inf=999999;  
const double eps=1e-5;  
int a[maxn];//表示集合的树  
int r[maxn];//表示树的高度  
void build(int n)//初始化  
{  
    for(int i=0;i<=n;i++)  
    {  
        a[i]=i;//父亲就是自己  
        r[i]=0;//高度为0   
    }  
}  
  
int find(int x)//查找节点的父亲  
{  
    if(a[x]==x)  
        return x;  
    return a[x]=find(a[x]);  
}  
  
void add(int x,int y)//节点的合并  
{  
    x=find(a[x]);  
    y=find(a[y]);  
    if(x==y)  
        return;  
    else if(r[x]<r[y])  
        a[x]=y;  
    else  
    {  
        a[y]=x;  
        if(r[x]==r[y])r[x]++;  
    }  
}  
  
bool same(int x,int y)//判断是不是一个集合  
{  
    return find(x)==find(y);  
}  
  
int main()  
{  
    int n,m,i,j,k,t;  
    cin>>n;  
    build(n);  
    while(1)  
    {  
        char op[2];  
        cin>>op;  
        if(op[0]=='I')  
        {  
            cin>>i>>j;  
            add(i,j);  
        }  
        else if(op[0]=='C')  
        {  
            cin>>i>>j;  
            if(same(i,j))  
                puts("yes");  
            else  
                puts("no");  
        }  
        else if(op[0]=='S')  
        {  
            int cnt=0;  
            for(i=1;i<=n;i++)  
                if(i==a[i])cnt++;  
            if(cnt<=1)  
                puts("The network is connected.");  
            else  
                printf("There are %d components.\n",cnt);  
            break;  
        }  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值