H - Can you answer these queries? HDU 4027 (线段树+延迟标记+开根号的速度)


H - Can you answer these queries?
Time Limit:2000MS Memory Limit:65768KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 4027

Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.


Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.


Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.


Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8



Sample Output

Case #1:
19
7

6

一开始想到每次开根号要更新到叶子结点,肯定会超时,但是开根号到一的速度是很快的,只需要添加一个延迟标记,即已经全是一的区间就不用向下更新了

这样就节约了时间

//#include<bits/stdc++.h>
#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<cstdio>
#include<map>
#include<algorithm>
using namespace std;
const int maxn=100011;
const int inf=999999999;
#define lson (rt<<1),L,M
#define rson (rt<<1|1),M+1,R
#define M ((L+R)>>1)
#define For(i,n) for(int i=0;i<(n);i++)
template<class T>inline T read(T&x)
{
    char c;
    while((c=getchar())<=32);
    bool ok=false;
    if(c=='-')ok=true,c=getchar();
    for(x=0; c>32; c=getchar())
        x=x*10+c-'0';
    if(ok)x=-x;
    return x;
}
template<class T> inline void read_(T&x,T&y)
{
    read(x);
    read(y);
}
template<class T> inline void read__(T&x,T&y,T&z)
{
    read(x);
    read(y);
    read(z);
}
template<class T> inline void write(T x)
{
    if(x<0)putchar('-'),x=-x;
    if(x<10)putchar(x+'0');
    else write(x/10),putchar(x%10+'0');
}
template<class T>inline void writeln(T x)
{
    write(x);
    putchar('\n');
}
//-------IO template------
typedef long long  LL;

struct node
{
    LL inv;///0 表示不开跟号,>=1,表示开跟号
    LL sum;
} p[maxn<<2];

void build(int rt,int L,int R)
{
    p[rt].inv=1;
    p[rt].sum=0;
    if(L==R)
    {
        read(p[rt].sum);
        p[rt].inv=1;
        return;
    }
    build(lson);
    build(rson);
    p[rt].sum=p[rt<<1].sum+p[rt<<1|1].sum;
}

void update(int rt,int L,int R,int x,int y)
{
    //printf("%d %d %d %d %d\n",rt,L,R,x,y);
    if(L==R)
    {
        if(p[rt].inv)
        {
            p[rt].sum=(int)sqrt(p[rt].sum);
            if(p[rt].sum==1)p[rt].inv=0;
        }
        return ;
    }
    if(L==x&&y==R&&p[rt].inv==0)
    {
        return;
    }
//    if(p[rt].inv)
//    {
//        p[rt<<1].inv=p[rt<<1|1].inv=p[rt].inv;
//        p[rt].inv=0;
//    }
    if(y<=M)
        update(lson,x,y);
    else if(x>M)
        update(rson,x,y);
    else
    {
        update(lson,x,M);
        update(rson,M+1,y);
    }
    p[rt].sum=p[rt<<1].sum+p[rt<<1|1].sum;
    p[rt].inv=p[rt<<1].inv+p[rt<<1|1].inv;
}

LL query(int rt,int L,int R,int x,int y)
{
    if(L==x&&y==R)
    {
        return p[rt].sum;
    }
    if(y<=M)
        return query(lson,x,y);
    else if(x>M)
        return query(rson,x,y);
    else
    {
        return query(lson,x,M)+query(rson,M+1,y);
    }
}

int main()
{
    int n,m;
    //freopen("in.txt","r",stdin);
    int cas=1;
    while(~scanf("%d",&n))
    {
        printf("Case #%d:\n",cas++);
        build(1,1,n);
        int a,b,c;
        read(m);
        while(m--)
        {
            read__(a,b,c);
            //printf("%d %d %d\n",a,b,c);
            if(b>c)swap(b,c);
            if(a==0)
            {
                 update(1,1,n,b,c);
            }
            else
            {
                writeln(query(1,1,n,b,c));
            }
        } printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值