HDU 1885Key Task(bfs + 状态压缩)

Key Task
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1529 Accepted Submission(s): 631

Problem Description
The Czech Technical University is rather old — you already know that it celebrates 300 years of its existence in 2007. Some of the university buildings are old as well. And the navigation in old buildings can sometimes be a little bit tricky, because of strange long corridors that fork and join at absolutely unexpected places.

The result is that some first-graders have often di?culties finding the right way to their classes. Therefore, the Student Union has developed a computer game to help the students to practice their orientation skills. The goal of the game is to find the way out of a labyrinth. Your task is to write a verification software that solves this game.

The labyrinth is a 2-dimensional grid of squares, each square is either free or filled with a wall. Some of the free squares may contain doors or keys. There are four di?erent types of keys and doors: blue, yellow, red, and green. Each key can open only doors of the same color.

You can move between adjacent free squares vertically or horizontally, diagonal movement is not allowed. You may not go across walls and you cannot leave the labyrinth area. If a square contains a door, you may go there only if you have stepped on a square with an appropriate key before.

Input
The input consists of several maps. Each map begins with a line containing two integer numbers R and C (1 ≤ R, C ≤ 100) specifying the map size. Then there are R lines each containing C characters. Each character is one of the following:

Note that it is allowed to have
more than one exit,

no exit at all,

more doors and/or keys of the same color, and

keys without corresponding doors and vice versa.

You may assume that the marker of your position (“*”) will appear exactly once in every map.

There is one blank line after each map. The input is terminated by two zeros in place of the map size.

Output
For each map, print one line containing the sentence “Escape possible in S steps.”, where S is the smallest possible number of step to reach any of the exits. If no exit can be reached, output the string “The poor student is trapped!” instead.

One step is defined as a movement between two adjacent cells. Grabbing a key or unlocking a door does not count as a step.

Sample Input

1 10
*……..X

1 3
*#X

3 20

#

XY.gBr.*.Rb.G.GG.y

#

0 0

Sample Output

Escape possible in 9 steps.
The poor student is trapped!
Escape possible in 45 steps.

Source
2008 “Shun Yu Cup” Zhejiang Collegiate Programming Contest - Warm Up(2)

因为只有4个门,所以2^4=16,就可以表示出,所有钥匙的组合,
到达每一个点除坐标外,还应该有第三个状态,就是钥匙的状态
所以vis开三维


#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define cl(a,b) memset(a,b,sizeof(a))
const int maxn=102;
const int inf=9999999;

int n,m;
char a[maxn][maxn];
int si,sj;
int vis[17][maxn][maxn];
int dir[][2]={{1,0},{0,1},{-1,0},{0,-1}};

struct node {
    int x,y,step,cnt;
    node(int a,int b,int c,int d){
        x=a,y=b,step=c,cnt=d;
    }
};
bool pan(node s){
    if(s.x<0||s.x>=n||s.y<0||s.y>=m||a[s.x][s.y]=='#')
        return false;
    return true;
}
int getCode(char s){
    if(s=='B'||s=='b')return 0;
    if(s=='Y'||s=='y')return 1;
    if(s=='r'||s=='R')return 2;
    if(s=='G'||s=='g')return 3;
}
int bfs(){
    cl(vis,0);
    queue<node> q;
    q.push(node(si,sj,0,0));
    vis[0][si][sj]=1;

    while(!q.empty()){

        node s=q.front();q.pop();
        for(int i=0;i<4;i++){
            node tmp=s;
            tmp.x+=dir[i][0];
            tmp.y+=dir[i][1];
            tmp.step++;
            if(pan(tmp)&&!vis[tmp.cnt][tmp.x][tmp.y]){

                if(a[tmp.x][tmp.y]=='X'){
                    return tmp.step;
                }

                if(a[tmp.x][tmp.y]=='.'||a[tmp.x][tmp.y]=='*'){
                    vis[tmp.cnt][tmp.x][tmp.y]=1;
                    q.push(tmp);
                }
                else if(a[tmp.x][tmp.y]>='B'&&a[tmp.x][tmp.y]<='Y'){
                    int d=getCode(a[tmp.x][tmp.y]);
                    if(tmp.cnt>>d&1){
                        q.push(tmp);
                        vis[tmp.cnt][tmp.x][tmp.y]=1;
                    }
                }
                else if(a[tmp.x][tmp.y]>='b'&&a[tmp.x][tmp.y]<='y'){
                    int d=getCode(a[tmp.x][tmp.y]);
                    tmp.cnt|=1<<d;
                    q.push(tmp);
                    vis[tmp.cnt][tmp.x][tmp.y]=1;

                }
            }
        }
    }
    return -1;
}

int main(){
    while(scanf("%d%d",&n,&m)&&(n||m)){
        for(int i=0;i<n;i++){
            scanf("%s",a[i]);
            for(int j=0;j<m;j++){
                if(a[i][j]=='*'){
                    si=i;sj=j;
                }
            }
        }
        int ans=bfs();
        if(ans!=-1){
            printf("Escape possible in %d steps.\n",ans);
        }else {
            printf("The poor student is trapped!\n");
        }

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值