UVA - 10305 (Ordering Tasks) 拓扑排序

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu

Submit Status

Description

Download as PDF

Problem F

Ordering Tasks

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

 

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100and mn is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance withn = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3
#include<iostream>
#include<cstring>
using namespace std;
//int did[111][111],ne[111][111],c[111],n;
//int topo[111],t,G[222][111];
#define max 111
int c[max],topo[max],t,n,G[max][max];
int dfs(int u)
{
	int v;
    c[u] = -1;	//正在访问
    for(v = 1; v <= n; v++)
        if(G[u][v])
        {
            if(c[v] < 0) return 0;	//V正在访问,当前U其实是由V而来的,现在又指向V,即成环
            else if(!c[v] && !dfs(v)) return 0;
        }
    c[u] = 1;	//访问结束
    topo[--t] = u;	//从后往前保存--回溯
	return 1;
}
int toposort()
{
    int i;
    t = n;
    memset(c,0,sizeof(c));
    for(i = 1; i <= n; i++)
        if(!c[i] && !dfs(i))
                return 0;
    return  1;
}
int main()
{
	int i,j,m,x,y; 
	while(scanf("%d%d",&n,&m)!=EOF&&m+n)
	{
		//memset(topo,0,sizeof(topo));
		memset(G,0,sizeof(G));
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			G[x][y]=1;//
		}
		toposort();
		for(i = 0; i < n-1; i++)  
                printf("%d ",topo[i]);  
        printf("%d\n",topo[i]);
	}
	return 0;
}
/*
5 4
1 2
2 3
1 3
1 5
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值