UVA - 10305 (Ordering Tasks) 拓扑排序

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu

Submit Status

Description

Download as PDF

Problem F

Ordering Tasks

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

 

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100and mn is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance withn = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3
#include<iostream>
#include<cstring>
using namespace std;
//int did[111][111],ne[111][111],c[111],n;
//int topo[111],t,G[222][111];
#define max 111
int c[max],topo[max],t,n,G[max][max];
int dfs(int u)
{
	int v;
    c[u] = -1;	//正在访问
    for(v = 1; v <= n; v++)
        if(G[u][v])
        {
            if(c[v] < 0) return 0;	//V正在访问,当前U其实是由V而来的,现在又指向V,即成环
            else if(!c[v] && !dfs(v)) return 0;
        }
    c[u] = 1;	//访问结束
    topo[--t] = u;	//从后往前保存--回溯
	return 1;
}
int toposort()
{
    int i;
    t = n;
    memset(c,0,sizeof(c));
    for(i = 1; i <= n; i++)
        if(!c[i] && !dfs(i))
                return 0;
    return  1;
}
int main()
{
	int i,j,m,x,y; 
	while(scanf("%d%d",&n,&m)!=EOF&&m+n)
	{
		//memset(topo,0,sizeof(topo));
		memset(G,0,sizeof(G));
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			G[x][y]=1;//
		}
		toposort();
		for(i = 0; i < n-1; i++)  
                printf("%d ",topo[i]);  
        printf("%d\n",topo[i]);
	}
	return 0;
}
/*
5 4
1 2
2 3
1 3
1 5
*/

内容概要:本文详细介绍了施耐德M580系列PLC的存储结构、系统硬件架构、上电写入程序及CPU冗余特性。在存储结构方面,涵盖拓扑寻址、Device DDT远程寻址以及寄存器寻址三种方式,详细解释了不同类型的寻址方法及其应用场景。系统硬件架构部分,阐述了最小系统的构建要素,包括CPU、机架和模块的选择与配置,并介绍了常见的系统拓扑结构,如简单的机架间拓扑和远程子站以太网菊花链等。上电写入程序环节,说明了通过USB和以太网两种接口进行程序下载的具体步骤,特别是针对初次下载时IP地址的设置方法。最后,CPU冗余部分重点描述了热备功能的实现机制,包括IP通讯地址配置和热备拓扑结构。 适合人群:从事工业自动化领域工作的技术人员,特别是对PLC编程及系统集成有一定了解的工程师。 使用场景及目标:①帮助工程师理解施耐德M580系列PLC的寻址机制,以便更好地进行模块配置和编程;②指导工程师完成最小系统的搭建,优化系统拓扑结构的设计;③提供详细的上电写入程序指南,确保程序下载顺利进行;④解释CPU冗余的实现方式,提高系统的稳定性和可靠性。 其他说明:文中还涉及一些特殊模块的功能介绍,如定时器事件和Modbus串口通讯模块,这些内容有助于用户深入了解M580系列PLC的高级应用。此外,附录部分提供了远程子站和热备冗余系统的实物图片,便于用户直观理解相关概念。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值