【HDU4722】【Good Numbers】

Good Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3470    Accepted Submission(s): 1099


Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
 

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

Sample Input
  
  
2 1 10 1 20
 

Sample Output
  
  
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.
 

Source
 

Recommend
zhuyuanchen520

<span style="font-size:14px;background-color: rgb(255, 255, 153);">return dp[len][n] = ret;</span>
这句话开始写错了,然后各种wa



#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
__int64 T;

__int64 dp[20][25];
char s[50];
__int64 f(int len,int n) // return a single ans 长度为len,各位和mod10 = n
{
	if(len == 0) return n == 0;
	if(dp[len][n]>=0 ) return dp[len][n];
	dp[len][n] = 0;
	__int64 ret = 0LL;
	for(int i=9;i>=0;i--)
	{
		ret += f(len-1,i);
	}
	return dp[len][n] = ret;
}

__int64 solve(__int64 x) // return all the ans of <=x 
{
	__int64 ret = 0;
	sprintf(s,"%I64d",x);
	int len = strlen(s);
	int curlen = len;
	int sum = 0;
	for(int i=0;i<len;i++)
	{
		int d = s[i] - '0';
		curlen --;
		for(int j=0;j<d;j++)
		{	
			int tmp = (sum + j) % 10; 
			ret += f(curlen,(10-tmp) % 10);
		}
		sum = (sum + d) % 10;
	}
	return ret;
}
int main()
{
    scanf("%I64d",&T);
	int C = 1;
	memset(dp,-1,sizeof(dp));
	while(T--)
	{
	
		__int64 l,r;
		scanf("%I64d%I64d",&l,&r);
		printf("Case #%d: %I64d\n",C++,solve(r+1)-solve(l));
		cout << endl;
	}
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值