Good Numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3470 Accepted Submission(s): 1099
Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
You are required to count the number of good numbers in the range from A to B, inclusive.
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
Sample Input
2 1 10 1 20
Sample Output
Case #1: 0 Case #2: 1HintThe answer maybe very large, we recommend you to use long long instead of int.
Source
Recommend
zhuyuanchen520
<span style="font-size:14px;background-color: rgb(255, 255, 153);">return dp[len][n] = ret;</span>
这句话开始写错了,然后各种wa
#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
__int64 T;
__int64 dp[20][25];
char s[50];
__int64 f(int len,int n) // return a single ans 长度为len,各位和mod10 = n
{
if(len == 0) return n == 0;
if(dp[len][n]>=0 ) return dp[len][n];
dp[len][n] = 0;
__int64 ret = 0LL;
for(int i=9;i>=0;i--)
{
ret += f(len-1,i);
}
return dp[len][n] = ret;
}
__int64 solve(__int64 x) // return all the ans of <=x
{
__int64 ret = 0;
sprintf(s,"%I64d",x);
int len = strlen(s);
int curlen = len;
int sum = 0;
for(int i=0;i<len;i++)
{
int d = s[i] - '0';
curlen --;
for(int j=0;j<d;j++)
{
int tmp = (sum + j) % 10;
ret += f(curlen,(10-tmp) % 10);
}
sum = (sum + d) % 10;
}
return ret;
}
int main()
{
scanf("%I64d",&T);
int C = 1;
memset(dp,-1,sizeof(dp));
while(T--)
{
__int64 l,r;
scanf("%I64d%I64d",&l,&r);
printf("Case #%d: %I64d\n",C++,solve(r+1)-solve(l));
cout << endl;
}
return 0;
}