Happy 2006

M - Happy 2006
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006. 

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order. 

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5
只能说很水的一道题,当时考虑的时候忘记考虑超过2006的情况,一直以为后面的会比前面的小,
考虑到这个情况也应该注意不要超时,如果gcd(a,i)==1那么gcd(a*t+i,i)==1。这样会
大大节约时间,看到一个题目,首先想到的与之相关的算法。而不是耍聪明,自以为.
这个题目就是容斥原理的运用。
#include<stdio.h>
__int64 s[1001000];
long f(long  a,long  b)
{
    if(b==0)
    return a;
    return  f(b,a%b);
}
int main()
{
   __int64 m,n;
    __int64 i;

    while(~scanf("%I64d%I64d",&m,&n))
    {
       __int64 t=0;
        for(i=1;i<=m;i++)
        {
            if(f(m,i)==1)
            s[t++]=i;

        }
        __int64 sum=n/t*m+s[n%t-1];
        __int64 tun=(n/t-1)*m+s[t-1];
        if(n%t)
        printf("%I64d\n",sum);
        else
        printf("%I64d\n",tun);
    }
    return 0;
}


 
  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值