母函数的运算

F - Ignatius and the Princess III
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. 

"The second problem is, given an positive integer N, we define an equation like this: 
  N=a[1]+a[2]+a[3]+...+a[m]; 
  a[i]>0,1<=m<=N; 
My question is how many different equations you can find for a given N. 
For example, assume N is 4, we can find: 
  4 = 4; 
  4 = 3 + 1; 
  4 = 2 + 2; 
  4 = 2 + 1 + 1; 
  4 = 1 + 1 + 1 + 1; 
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!" 
 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file. 
 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found. 
 

Sample Input

     
     
4 10 20
 

Sample Output

     
     
5 42 627
了解了定义,感觉做题也有了感觉了呢。
“母函数的思想很简单—就是把离散 数列幂级数一一对应起来,把离散数列间的相互结合关系对应成为幂级数间的运算关系,最后由幂级数形式来确定离散数列的构造. “
我们首先来看下这个多项式 乘法: (以下图片都可以点击放大)
母函数详解

母函数详解

由此可以看出:
1.x的系数是a1,a2,…an 的单个组合的全体。
2. x2的系数是a1,a2,…a2的两个组合的全体。
………
n. xn的系数是a1,a2,….an的n个组合的全体(只有1个)。
#include<stdio.h>
#include<string.h>
int main()
{
    int a,i,j,k;
    int sum1[10010],sum2[10002];
    while(~scanf("%d",&a))
    {
        for(i=0;i<=a;i++)
        {
        sum1[i]=1;//初始化一个数组,并且定义为1,由于自身的原因。
        sum2[i]=0;//另定义的一个数组,便于下面计算
        }
        for(i=2;i<=a;i++)
        {
            for(j=0;j<=a;j++)
            for(k=0;k+j<=a;k+=i)
            sum2[k+j]+=sum1[j];//将每次所满足的一次结果存入sum2数组中
            for(j=0;j<=a;j++)
            {
                sum1[j]=sum2[j];//将每次所得结果存入sum1中,
                sum2[j]=0;//对um2进行清零。便于下次计算。
            }
        }
        printf("%d\n",sum1[a]);//输出结果。
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值