Number Transformation

14 篇文章 0 订阅
8 篇文章 0 订阅

Number Transformation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 514    Accepted Submission(s): 260


Problem Description
Teacher Mai has an integer x.

He does the following operations k times. In the i-th operation, x becomes the least integer no less than x, which is the multiple of i.

He wants to know what is the number x now.
 

Input
There are multiple test cases, terminated by a line "0 0".

For each test case, the only one line contains two integers x,k(1<=x<=10^10, 1<=k<=10^10).
 

Output
For each test case, output one line "Case #k: x", where k is the case number counting from 1.
 

Sample Input
  
  
2520 10 2520 20 0 0
 

Sample Output
  
  
Case #1: 2520 Case #2: 2600
 

Source
这题目出的,让我都不知道怎么用汉语表达了
题意:输入两个数,x,k.要保证从1~k一个一个都能被整除。并且要保证这个数据比前面x要大或者相等

例如:2520 20 前面10位都能被2520整除,当i变到11.x就会变成2530.2530/11=230;并且2530》2520;

分析:设第i个数为i*a;第i+1个数为(i+1)*b。则(i+1)*b>i*a;b>a-(a/(i+1));那么如果a<i+1;b的值就会不变
此时k*b就为所求;而由于a在不断的变小,a<i+1;在数值比较大的情况下就能实现;

下面看代码实现:
#include<stdio.h>
int main()

{
    int t=0;
    __int64 a,b,i,j;
    while(scanf("%I64d%I64d",&a,&b),a||b)
    {
        t++;
      for(i=2;i<=b;i++)
      {
          if(a%i!=0)
          {
              j=a/i+1;
             a=i*j;//普通情况下的求解
                }
          else
                {
                    j=a/i;//计算出j的数值,便于判断。
                }
                if(j<i)
                {
                    a=j*b;
                    break;//当数值满足j<i;就会跳出:
                }
    }
    printf("Case #%d: %I64d\n",t,a);
    }
    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值