01背包,买东西

题目:

Description

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more. 
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi. 
If he had M units of money, what’s the maximum value iSea could get? 

 

Input

There are several test cases in the input. 

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money. 
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description. 

The input terminates by end of file marker. 

 

Output

For each test case, output one integer, indicating maximum value iSea could get. 

 

Sample Input

       
       
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output

       
       
5 11
 

同学说这个题需要以价格和需要钱数的差值排序,我没有那样做,虽然过了,但是我觉得我这样做有问题。

代码:


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
	int a;
	int b;
	int c;
} ;
bool cmp(node a,node b)
{
	if(a.b!=b.b) return a.b>b.b;
	return a.a<b.a;
}
bool cmp2(node a,node b)
{
	if(a.b!=b.b) return a.b<b.b;
	return a.a<b.a;
}
main()
{
	int f[5010],f2[5010];
	int i;
    struct node p[5550];
	int sum;
	int n,V,v;

	
    while(scanf("%d%d",&n,&V)!=EOF)
	{
		memset(f,0,sizeof(f));
		memset(f2,0,sizeof(f2));
		
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d",&p[i].a,&p[i].b,&p[i].c);
			
		}
		
		
		sort(p,p+n,cmp);
		
	
		for(i=0;i<n;i++)
		{
			for(v=V;v>=p[i].b;v--)
			{
				if(f[v]<f[v-p[i].a]+p[i].c)
				f[v]=f[v-p[i].a]+p[i].c;
			}
		}
		
		sort(p,p+n,cmp2);
		
		for(i=0;i<n;i++)
		{
			for(v=V;v>=p[i].b;v--)
			{
				if(f2[v]<f2[v-p[i].a]+p[i].c)
				f2[v]=f2[v-p[i].a]+p[i].c;
			}
		}
		
		if(f[V]>f2[V])
		sum=f[V];
		else
		sum=f2[V];
			
		printf("%d\n",sum);
	}
} 





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值