hduoj1002——A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
      
      
2 1 2 112233445566778899 998877665544332211
 

Sample Output
      
      
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 




#include<stdio.h>
#include<string.h>
main()
{
    int k=0;
    int f=0;
    int i;
    int a[1005],b[1005];
    char x[1005],y[1005];
    int t;
    int shu;
    int sum[1005];
    int n,m;
    scanf("%d",&t);
    while(t--)
    {
        k++;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(sum,0,sizeof(sum));
        scanf("%s%s",x,y);
        n=strlen(x);
        m=strlen(y);
        for(i=0;i<n;i++)
        {
            a[i]=x[n-i-1]-'0';
        }
        for(i=0;i<m;i++)
        {
            b[i]=y[m-i-1]-'0';
        }
        shu=0;
        for(i=0;i<1001;i++)
        {
            sum[i]=a[i]+b[i]+shu;
            shu=sum[i]/10;
            sum[i]=sum[i]%10;
        }
        i=1001;
        while(sum[i]==0)
        {
            i--;
        }
        if(f)
        printf("\n");
        f=1;
        printf("Case %d:\n",k);
        printf("%s + %s = ",x,y);
        for(;i>=0;i--)
        printf("%d",sum[i]);
        printf("\n");
    }
    
}




























  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值