2828Buy ticket

算是自己写的线段树吧,当然也参考了别人的代码,一次ac,小小的成就感
Buy Tickets
Time Limit: 4000MSMemory Limit: 65536K
Total Submissions: 11957Accepted: 5886

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i ? 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

2828Buy ticket - JIM - 叶沁寒

Source



#include<stdio.h>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=200000;
int i,re[maxn<<2];
struct node
{
int l;
int r;
int d;                          // d 表示 l 到 r 区间剩余的可加入的空白处
}max[maxn<<2];
struct lnode
{
int pos;                           
int val;
}ti[maxn<<2];                       //该数组用于存放输入的数据
void pushup(int rt)
{
max[rt].d=max[rt<<1].d+max[rt<<1|1].d;
}
void build(int l,int r,int rt)
{
max[rt].l=l;                       //把线段树存于数组里面,后面的更新update()直接更新数组
max[rt].r=r;
max[rt].d=r-l+1;
if(l==r)
return;
int m=(l+r)>>1;
build(lson);
build(rson);
pushup(rt);
}
void update(int w,int p)               
{
if(max[w].l==max[w].r)
{
re[max[w].l]=ti[i].val;                         // re[ ]数组用于存放输出的数
max[w].d--;                                       
return;
}
if(max[w<<1].d>=p)                         //此处可模拟一下,左边有位置让ti[i].val,  那么pos的值不用改变
update(w <<1,p);
else                                                   //否则,用pos值减去左子树的d值即max[w<<1].d,那么可以得到pos在右边的值
update(w <<1|1,p-max[w<<1].d);
pushup(w);
}
int main()
{
int t;
while(scanf("%d",&t)!=EOF)
{
build(1,t,1);
for(i=1;i<=t;i++)
scanf("%d%d",&ti[i].pos,&ti[i].val);             
for(i=t;i>0;i--)                        //倒序输入更新线段树刚好符合题目条件,自己试一下是那样的
update(1,ti[i].pos+1);
  for(i=1;i<t;i++)
  printf("%d ",re[i]);
  printf("%d\n",re[t]);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值