杭电1711 Number Sequence

3 篇文章 0 订阅

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10002    Accepted Submission(s): 4561


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
    
    
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
    
    
6 -1
#include<stdio.h>
#include<string.h>
int a,b,s[1111111],t[11111],next[11111]; 
void getnext()
{
int i=1,j=0;
next[1]=0;
while(i<b)
{
if(j==0||t[i]==t[j])
{
i++;
j++;
next[i]=j;
}
else
j=next[j];
   }
}
int kmp()
{
int i=1,j=1;
while(i<=a&&j<=b)
{
if(j==0||s[i]==t[j])
{
  i++;
  j++;
}
else
j=next[j];
if(j>b)
return i-b;
return 0;
    }
}
int main()
{
int T,ret;
scanf("%d",&T);
while(T--)
{
memset(s,0,sizeof(s));
memset(t,0,sizeof(t));
memset(next,0,sizeof(next));
scanf("%d%d",&a,&b);
for(int i=1;i<=a;i++)
scanf("%d",&s[i]);
for(int j=1;j<=b;j++)
scanf("%d",&t[j]);
getnext();
ret=kmp();
if(ret==0)
printf("-1\n");
else
printf("%d\n",ret);
}
}
搞了好久,终于发现错误了
#include<stdio.h>
#include<string.h>
int s[1111111],t[11111],next[11111];
int n,m;
void getnext()
{
int i=1,j=0;
next[1]=0;
while(i<m)                               //这里是<小于号,注意跟后面kmp的<=区别开来
{
if(j==0||t[i]==t[j])
{
i++;
j++;
next[i]=j;
}
else
j=next[j];
}
}
int kmp()
{
int i=1,j=1;
while(i<=n&&j<=m)                                       //这里是<=,后面的if(j>m)里面的符号就要大于
{
if(j==0||s[i]==t[j])
{
i++;
j++;
}
else
j=next[j];         
}
      if(j>m)                            //这语句应该写在while语句外面的 ,刚开始写在里面,然后找了我好几个小时
return i-m;
else
return 0;
}
int main()
{
int T,ret;
scanf("%d",&T);
while(T--)
{
memset(s,0,sizeof(s));
memset(t,0,sizeof(t));
memset(next,0,sizeof(next));
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)                           //定义的数组要从1开始,方便kmp的实现,如果是字符串就s+1,具
scanf("%d",&s[i]);                           //体见下一篇“剪布条”
for(int j=1;j<=m;j++)
scanf("%d",&t[j]);
getnext();
ret=kmp();
if(ret==0)
printf("-1\n");
else
printf("%d\n",ret);
}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值