UVA 10106 Product (大数相乘)

Product 

The Problem

The problem is to multiply two integers X, Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12
12
2
222222222222222222222222

Sample Output

144
444444444444444444444444


大数相乘,网上有很多模板,今下午练练手,自己写一遍,刚开始忽略了前置0,导致0*12=00,0*123=000,后来改了输出就ac了。

#include <iostream>
#include <cstring>
#define maxn 260
using namespace std;
int main()
{
    char str1[maxn],str2[maxn];
    while(cin>>str1>>str2)
	{		
		int len1,len2;
		len1=strlen(str1);
		len2=strlen(str2);
		
		int s1[maxn],s2[maxn];
		memset(s1,0,sizeof(s1));
		memset(s2,0,sizeof(s2));
		
		int i;
		for(i=0;i<len1;i++)
			s1[i]=str1[i]-'0';
		for(i=0;i<len2;i++)
			s2[i]=str2[i]-'0';
		
		int sum[maxn+maxn];
		memset(sum,0,sizeof(sum));
		int j,k;
		for(i=len2-1;i>=0;i--)
		{
			for(j=len1-1;j>=0;j--)
			{
				sum[i+j+1]=sum[i+j+1]+s2[i]*s1[j];
			}
		}
		for(k=len1+len2-1;k>=0;k--)
			if(sum[k]>=10)
			{
				int temp;
				temp=sum[k]%10;
				sum[k-1]=sum[k-1]+sum[k]/10;
				sum[k]=temp;
			}
			
			//if(sum[0]!=0)
			//	cout<<sum[0];
			bool flag=0;
			for(i=0;i<len1+len2-1;i++)
			{
				if(sum[i]!=0)
					flag=1;
				if(flag==1)
				cout<<sum[i];
			}
			cout<<sum[len1+len2-1];
			cout<<endl;
	}
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值