UVA 10115 Automatic Editing

15 篇文章 0 订阅
11 篇文章 0 订阅

字符串处理题,需要注意的是要一直替换到没有所给的字符串为止,所以可以在change函数里返回1(代表查找成功)和0(代表没有要替换的字符了)

Problem E: Automatic Editing

Source file:autoedit.{ccppjavapas}
Input file:autoedit.in
Output file:autoedit.out

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

RuleFindReplace-by
1.banbab
2.bababe
3.anaany
4.ba bhind the g

To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because thefind string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

 BeforeAfter
banana boatbabana boat
babana boatbababa boat
bababa boatbeba boat
beba boatbehind the goat

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

Example output:

behind the goat
shoe or shop
#include <cstdio>
#include<cmath>
#include<cstring>
#define MAX 260
#define smax 90
char str[MAX];char a[11][smax],b[11][smax];
int change(char *str1,char *str2,char *str3)
{
    int len1=strlen(str1),len2=strlen(str2);
    for(int i=0;i<=len1-len2;i++)
    {
        int ok=1;
        for(int k=0;k<len2;k++)
        {
            if(str1[i+k]!=str2[k])
            {
                ok=0;break;
            }
        }
        if(ok)
        {
            char ch[MAX]="\0";int t=0;
            for(int j=0;j<i;j++)
                ch[t++]=str1[j];
                strcat(ch,str3);
                t+=strlen(str3);
            for(int j=i+len2;j<len1;j++)
                ch[t++]=str1[j];
            ch[t]='\0';
            strcpy(str1,ch);
            return 1;
        }
    }
    return 0;
}
int main()
{
    //freopen("input.txt","r",stdin);
    int n;
    while(~scanf("%d\n",&n)&&n)
    {
       for(int i=1;i<=n;i++)
       {
           gets(a[i]);
           gets(b[i]);
       }
       gets(str);
       for(int i=1;i<=n;i++)
       {
           while(change(str,a[i],b[i])!=0);
       }
       puts(str);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值