POJ1300(欧拉回路)

Door Man
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2139 Accepted: 858

Description

You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc...). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you: 

  1. Always shut open doors behind you immediately after passing through 
  2. Never open a closed door 
  3. End up in your chambers (room 0) with all doors closed 

In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible. 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 
A single data set has 3 components: 

  1. Start line - A single line, "START M N", where M indicates the butler's starting room, and N indicates the number of rooms in the house (1 <= N <= 20). 
  2. Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read "5 7". The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors! 
  3. End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT". 

Note that there will be no more than 100 doors in any single data set.

Output

For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line "YES X", where X is the number of doors he closed. Otherwise, print "NO".

Sample Input

START 1 2
1

END
START 0 5
1 2 2 3 3 4 4




END
START 0 10
1 9
2
3
4
5
6
7
8
9

END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top



题目描述:
你是一座大庄园的管家。庄园有很多房间,编号为 0、1、2、3,...。你的主人是一个心不在焉的人,经常沿着走廊随意地把房间的门打开。多年来,你掌握了一个诀窍:沿着一个通道,穿过这些大房间,并把房门关上。你的问题是能否找到一条路径经过所有开着门的房间,并使得:

这题字符处理挺麻烦的。。。。
1) 通过门后立即把门关上;
2) 关上了的门不再打开;
3) 最后回到你自己的房间(房间 0),并且所有的门都已经关闭了。


以房间为顶点、连接房间之间的门为边构造图。根据题目的意思,输入文件中每个测试数据所构造的图都是连通的。本题实际上是判断一个图中是否存在欧拉回路或欧拉通路,要分两种情况考虑:
1:
如果所有的房间都有偶数个门(通往其他房间),那么有欧拉回路,可以从 0 号房间出发,回到 0 号房间。但是这种情况下,出发的房间必须为 0,因为要求回到 0 号房间。
2:
有两个房间的门数为奇数,其余的都是偶数,如果出发的房间和 0 号房间的门数都是奇数,那么也可以从出发的房间到达 0 号房间,并且满足题目要求。但是不能从房间 0 出发,必须从另一个门数为奇数的房间出发。

#include <cstdio>
#include <cstring>
int readLine( char* s )
{
	int L;
	for( L=0; ( s[L]=getchar() ) != '\n' && s[L] != EOF; L++ );
		s[L] = 0;
	return L;
}
int main( )
{
	int i, j;
	char buf[128];
	int M, N;
	int door[20];
	while( readLine(buf) )
	{
		if( buf[0]=='S' )
		{
			sscanf( buf, "%*s %d %d", &M, &N );
			for( i=0; i < N; i++ )
			door[i] = 0;
			int doors = 0;
			for( i=0; i<N; i++ )
			{
				readLine(buf);
				int k = 0; 
				
				while( sscanf(buf + k, "%d", &j) == 1 )
				{
					doors++;
					door[i]++;
					door[j]++;
					while( buf[k] && buf[k] == ' ' ) k++;
					while( buf[k] && buf[k] != ' ' ) k++;
				}
			}
			readLine( buf );
			
			int odd = 0, even = 0; 
			for( i=0; i<N; i++ )
			{
				if( door[i]%2==0 ) even++;
				else odd++;
			}
			if( odd==0 && M==0 ) printf( "YES %d\n", doors );
			else if( odd==2 && door[M]%2==1 && door[0]%2==1 && M!=0 )
				printf( "YES %d\n", doors );
			else printf( "NO\n" );
		}
		else if( !strcmp(buf, "ENDOFINPUT") )
			break;
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值