poj 1300 Door Man 欧拉回路

Door Man
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1918 Accepted: 749

Description

You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc...). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you: 

  1. Always shut open doors behind you immediately after passing through 
  2. Never open a closed door 
  3. End up in your chambers (room 0) with all doors closed 

In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible. 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 
A single data set has 3 components: 

  1. Start line - A single line, "START M N", where M indicates the butler's starting room, and N indicates the number of rooms in the house (1 <= N <= 20). 
  2. Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read "5 7". The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors! 
  3. End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT". 

Note that there will be no more than 100 doors in any single data set.

Output

For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line "YES X", where X is the number of doors he closed. Otherwise, print "NO".

Sample Input

START 1 2
1

END
START 0 5
1 2 2 3 3 4 4




END
START 0 10
1 9
2
3
4
5
6
7
8
9

END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10

Source

相当水的欧拉回路问题,就是输入真心蛋疼。。

学书上的用ssacnf函数,结果调试两个小时,不作死就不会死。。。。。。。。。。。。。。。。。。。。。

思路:

就是算每个房间门的个数,如果所有房间的门的数量都是偶数,那么存在欧拉回路,如果想要从回到0房间,那么起点必须是0;

另外,如果有两个房间的门的数量为奇数,其他的都是偶数,那么只能从另一个门数为奇数的房间出发才满足题目要求;

其他情形,都不能完成题目中所要求的任务,直接输出NO。

看看思路就行,代码照书上写的真心蛋疼。。。。

 #include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<string>
using namespace std;
int readline( char* s )
{
    int L;
    for( L=0; ( s[L] = getchar() ) != '\n' && s[L] != EOF; L++)
        ;
    s[L] = 0;
    return L;
}
int main()
{
    int i , j;
    char buf[150];
    int M , N;
    int door[20];
    while(readline(buf))
    {
        if(buf[0] == 'S')
        {
            sscanf( buf, "%*s %d %d", &M, &N );///printf("%dllllll\n\n", M);
            for(int i=0; i<N; ++i)
                {door[i] = 0;}
            int doors = 0;

            for(i=0; i<N; ++i)
            {
                readline(buf);
                int k = 0;
                while(sscanf(buf + k, "%d", &j) == 1)
                {
                    doors++;
                    door[i]++;
                    door[j]++;
                    while( buf[k] && buf[k] == ' ' ) k++;
                    while( buf[k] && buf[k] != ' ' ) k++;
                }
            }
            readline(buf);
            int odd = 0, even = 0;
            for(i=0; i<N; ++i)
            {
                if(door[i] % 2 == 0) even++;
                else odd++;
            }
            if(odd == 0 && M == 0) printf("YES %d\n", doors);
            else if(odd == 2 && door[M] % 2 == 1 && door[0] % 2 == 1 && M != 0)
                printf("YES %d\n", doors);
            else printf("NO\n");
        }
        else if(!strcmp(buf , "ENDOFINPUT"));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值