poj2551

Ones
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10813 Accepted: 6153

Description

Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?

Input

Each line contains a number n.

Output

Output the number of digits.

Sample Input

3 
7 
9901

Sample Output

3
6
12
源代码:
#include<iostream>
using namespace std;
int main()
{
    int s,n,t;
    while(cin>>s)
    {


        n=1,t=1;
        while(n!=0)
        {
            while(n<s) n=n*10+1,t++;
            n=n%s; 
        }
		cout<<t<<endl;
    }
	return 0;
}
本题是一道对除法的新定义,平常除法除尽余数为0,此为1,掌握了这个原理写起来就十分简单了。
题目意思也很好理解,继续a题去了~
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值