poj1014

Dividing
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 61037 Accepted: 15763

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.
#include<iostream>
#include<cstring>
using namespace std;
int t[6];
bool DFS(int sum)
{
	int i;
	if(sum==0) return true;
	for(i=6;i>1;i--)
	{
		if(sum>=i && t[i-1]>0)
		{
			t[i-1]--;
			int value=sum-i;
			if(DFS(value))return true;
		}
	}
	return false;
}
int main()
{                                              
    int i,k=1,sval;
	for (;;)
	{  
	    sval=0;
	    for (i=0;i<6;i++)
		{
	       cin>>t[i];
		   sval+=(i+1)*t[i];
		}
		if (sval==0) {break;}
		else if (sval%2!=0)
		{
			cout<<"Collection #"<<k++<<':'<<endl;
			cout<<"Can't be divided."<<endl<<endl;
		}
		else
		{
		    if(DFS(sval/2))  
			{  
                cout<<"Collection #"<<k++<<':'<<endl;  
                cout<<"Can be divided."<<endl<<endl;  
			}  
            else  
			{  
                cout<<"Collection #"<<k++<<':'<<endl;  
                cout<<"Can't be divided."<<endl<<endl;  
			}  
		}
		
	}	    
	return 0;
}
题目大意,就是1-6的价值的物品,你给出每个物品的数量,然后平分,看你给出的数据能够完成平分吗。我用dfs做的,首先判断你给出的物品总值是否能够平分,一切实在能被平分的前提下进行的,然后从价值最大的开始dfs,用减法的方式去削减物品的价值,直到价值为0时说明有可能平分,从最大值开始也是为了以最快的方式找到方法,因为平分的话,最大的那个肯定是会被占用的,所以不管加减法都是从顶开始深搜,以求效率,最后16ms通过,应该算快的了。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值