【HDU】4849 Wow! Such City! 最短路

Wow! Such City!

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 110    Accepted Submission(s): 50


Problem Description
Doge, tired of being a popular image on internet, is considering moving to another city for a new way of life.
In his country there are N (2 ≤N≤ 1000) cities labeled 0 . . . N - 1. He is currently in city 0. Meanwhile, for each pair of cities, there exists a road connecting them, costing Ci,j (a positive integer) for traveling from city i to city j. Please note that Ci,j may not equal to Cj,i for any given i ≠ j.
Doge is carefully examining the cities: in fact he will divide cities (his current city 0 is NOT included) into M (2 ≤ M ≤ 106) categories as follow: If the minimal cost from his current city (labeled 0) to the city i is Di, city i belongs to category numbered Di mod M.Doge wants to know the “minimal” category (a category with minimal number) which contains at least one city.
For example, for a country with 4 cities (labeled 0 . . . 3, note that city 0 is not considered), Doge wants to divide them into 3 categories. Suppose category 0 contains no city, category 1 contains city 2 and 3, while category 2 contains city 1, Doge consider category 1 as the minimal one.
Could you please help Doge solve this problem?

Note:

Ci,j is generated in the following way:
Given integers X0, X1, Y0, Y1, (1 ≤ X0, X1, Y0, Y1≤ 1234567), for k ≥ 2 we have
Xk  = (12345 + Xk-1 * 23456 + Xk-2 * 34567 + Xk-1 * Xk-2 * 45678)  mod  5837501
Yk  = (56789 + Yk-1 * 67890 + Yk-2 * 78901 + Yk-1 * Yk-2 * 89012)  mod  9860381
The for k ≥ 0 we have

Zk = (Xk * 90123 + Yk ) mod 8475871 + 1

Finally for 0 ≤ i, j ≤ N - 1 we have

Ci,j = Zi*n+j for i ≠ j
Ci,j = 0   for i = j
 

Input
There are several test cases. Please process till EOF.
For each test case, there is only one line containing 6 integers N,M,X0,X1,Y0,Y1.See the description for more details.
 

Output
For each test case, output a single line containing a single integer: the number of minimal category.
 

Sample Input
  
  
3 10 1 2 3 4 4 20 2 3 4 5
 

Sample Output
  
  
1 10 For the first test case, we have 0 1 2 3 4 5 6 7 8 X 1 2 185180 788997 1483212 4659423 4123738 2178800 219267 Y 3 4 1633196 7845564 2071599 4562697 3523912 317737 1167849 Z 90127 180251 1620338 2064506 625135 5664774 5647950 8282552 4912390 the cost matrix C is  0 180251 1620338  2064506 0 5664774  5647950 8282552 0 So the minimal cost from city 0 to city 1 is 180251, while the distance to city 2 is 1620338. Given M = 10, city 1 and city 2 belong to category 1 and 8 respectively. Since only category 1 and 8 contain at least one city, the minimal one of them, category 1, is the desired answer to Doge’s question.
 

Source
2014西安全国邀请赛

传送门:【HDU】4849 Wow! Such City!

题目大意:别看那么长一串,就是让你求最短路!存在点0到点i的距离Di使得Di%M的值最小。

题目分析:题目描述的那么多,就是告诉你两点之间的距离公式。。然后根据公式得到两点间的距离以后,用朴素的DIjkstra求以0为起点的单源最短路即可。Di%M的最小值就是除0以外的所有点的到0的距离%M的最小值。
为什么不用队优化?因为是完全图,优化效果不明显,而且我只会手敲堆。

代码如下:

#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std ;

typedef long long LL ;

#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define clear( a , x ) memset ( a , x , sizeof a )

const LL INF = 1000000000000000LL ;
const int MAXN = 1005 ;

LL d[MAXN] ;
LL C[MAXN][MAXN] ;
LL X[MAXN * MAXN] , Y[MAXN * MAXN] , Z[MAXN * MAXN] ;
int done[MAXN] ;
int n , m ; 

LL Dijkstra () {
        REP ( i , n )
            d[i] = INF ;
        d[0] = 0 ;
        clear ( done , 0 ) ;
        while ( 1 ) {
            int x ;
            LL m = INF ;
            REP ( i , n )
                if ( !done[i] && m > d[i] )
                    m = d[x = i] ;
            if ( m == INF )
                    break ;
            done[x] = 1 ;
            REP ( i , n )
                if ( d[i] > d[x] + C[x][i] )
                    d[i] = d[x] + C[x][i] ;
        }
        //for ( int i = 0 ; i < n ; ++ i ) printf ( "%I64d " , d[i] ) ;
        LL ans = INF ;
        for ( int i = 1 ; i < n ; ++ i )
            ans = min ( ans , d[i] % m ) ;
        return ans ;
}

void work () {
        while ( ~scanf ( "%d%d%I64d%I64d%I64d%I64d" , &n , &m , &X[0] , &X[1] , &Y[0] , &Y[1] ) ) {
            int nn = n * n ;
            for ( int i = 2 ; i < nn ; ++ i ) {
                    X[i] = (12345 + X[i - 1] * 23456 + X[i - 2] * 34567 + X[i - 1] * X[i - 2] * 45678) % 5837501 ;
                    Y[i] = (56789 + Y[i - 1] * 67890 + Y[i - 2] * 78901 + Y[i - 1] * Y[i - 2] * 89012) % 9860381 ;
            }
            REP ( i , nn )
                Z[i] = (X[i] * 90123 + Y[i] ) % 8475871 + 1 ;
            REP ( i , n )
                REP ( j , n )
                    C[i][j] = ( i == j ? 0 : Z[i * n + j] ) ;
            LL ans = Dijkstra () ;
            printf ( "%I64d\n" , ans ) ;
        }
}

int main () {
    work () ;
    return 0 ;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值