【HDU】3394 Railway 点双连通求块

Railway

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1046    Accepted Submission(s): 398


Problem Description
There are some locations in a park, and some of them are connected by roads. The park manger needs to build some railways along the roads, and he would like to arrange tourist routes to each circuit. If a railway belongs to more than one tourist routes, there might be clash on it, and if a railway belongs to none tourist route, it doesn’t need to build.
Now we know the plan, and can you tell us how many railways are no need to build and how many railways where clash might happen.
 

Input
The Input consists of multiple test cases. The first line of each test case contains two integers, n (0 < n <= 10000), m (0 <= m <= 100000), which are the number of locations and the number of the railways. The next m lines, each line contains two integers, u, v (0 <= u, v < n), which means the manger plans to build a railway on the road between u and v.
You can assume that there is no loop and no multiple edges.
The last test case is followed by two zeros on a single line, which means the end of the input.
 

Output
Output the number of railways that are no need to build, and the number of railways where clash might happen. Please follow the format as the sample.
 

Sample Input
  
  
8 10 0 1 1 2 2 3 3 0 3 4 4 5 5 6 6 7 7 4 5 7 0 0
 

Sample Output
  
  
1 5
 

Author
momodi@whu
 

Source
The 5th Guangting Cup Central China Invitational Programming Contest

传送门:【HDU】3394 Railway

题目大意:一个公园里面有n个景点,建设了m条道路,现在该建设者想知道如果为每个环形的路线选择旅游团,是否可能有的路会发生旅游团之间的争吵。争吵的定义是:两个旅游团出现在了同一条路径上,即存在两个环形路线部分道路重叠。并且他还想知道有哪些道路是不需要建设的,一条道路不在任何环形路线上的称之为不需要建设的路线。你的任务是输出不需要建设的道路的数量以及旅游团可能会发生争吵的道路的数量。

题目分析:不需要建设的道路就是桥。一个环形路线其实就是点连通分量。可能会发生争吵的道路我们可以这样分析:如果一个x个点的点连通分量里面包括x条边,则该连通分量中恰好包括一个环,如果有超过x条边,则说明至少有三个环(随便加一条边就有三个环),则所有的边都是会发生争吵的边。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;

#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REPV( i , a , b ) for ( int i = a ; i >= b ; -- i )
#define clear( a , x ) memset ( a , x , sizeof a )

const int MAXN = 10005 ;
const int MAXE = 100005 ;
const int INF = 0x3f3f3f3f ;

struct Edge {
	int v , n ;
	Edge ( int var = 0 , int next = 0 ) :
		v ( var ) , n ( next ) {}
} ;

struct BCC {
	Edge edge[MAXE << 1] ;
	int adj[MAXN] , cntE ;
	int bcc[MAXN] ;
	int low[MAXN] , dfn[MAXN] , dfs_clock ;
	int S[MAXN] , top ;
	int clash_way , bridge ;
	bool vis[MAXN] ;
	
	void init () {
		top = cntE = dfs_clock = 0 ;
		clash_way = bridge = 0 ;
		clear ( dfn , 0 ) ;
		clear ( adj , -1 ) ;
	}
	
	void addedge ( int u , int v ) {
		edge[cntE] = Edge ( v , adj[u] ) ;
		adj[u] = cntE ++ ;
		edge[cntE] = Edge ( u , adj[v] ) ;
		adj[v] = cntE ++ ;
	}
	
	void circuit () {
		int cnt = 0 ;
		clear ( vis , 0 ) ;
		REPF ( i , 1 , bcc[0] )
			vis[bcc[i]] = 1 ;
		REPF ( _ , 1 , bcc[0] ) {
			int u = bcc[_] ;
			for ( int i = adj[u] ; ~i ; i = edge[i].n )
				if ( vis[edge[i].v] )
					++ cnt ;
		}
		cnt >>= 1 ;//每条边计数了两次,要除以二
		if ( cnt > bcc[0] )//this bcc have more than one circles
			clash_way += cnt ;
	}
	
	void tarjan ( int u , int fa ) {
		low[u] = dfn[u] = ++ dfs_clock ;
		S[top ++] = u ;
		for ( int i = adj[u] ; ~i ; i = edge[i].n ) {
			int v = edge[i].v ;
			if ( !dfn[v] ) {
				tarjan ( v , u ) ;
				low[u] = min ( low[u] , low[v] ) ;
				if ( low[v] >= dfn[u] ) {//u is cut 
					if ( low[v] > dfn[u] )//(u,v) is bridge
						++ bridge ;
					bcc[0] = 0 ;
					while ( 1 ) {
						int x = S[-- top] ;
						bcc[++ bcc[0]] = x ;
						if ( x == v )
							break ;
					}
					bcc[++ bcc[0]] = u ;
					circuit () ;
				}
			}
			else if ( v != fa )
				low[u] = min ( low[u] , dfn[v] ) ;
		}
	}
	
	void solve ( int n ) {
		REPF ( i , 1 , n )
			if ( !dfn[i] )
				tarjan ( i , -1 ) ;
		printf ( "%d %d\n" , bridge , clash_way ) ;
	}
} ;

BCC c ;

void work () {
	int n , m ;
	int u , v ;
	while ( ~scanf ( "%d%d" , &n , &m ) && ( n || m ) ) {
		c.init () ;
		REP ( i , m ) {
			scanf ( "%d%d" , &u , &v ) ;
			c.addedge ( u , v ) ;
		}
		c.solve ( n ) ;
	}
}

int main () {
	work () ;
	return 0 ;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
好的,关于 HDU4992 求所有原根的问题,我可以给出以下解答: 1. 首先,我们需要知道什么是原根。原根是指模 n 意义下,所有与 n 互质的数 a 的最小正整数 k 次幂对 n 取模的值覆盖了所有与 n 互质的数。简单来说,就是如果一个数 a 是模 n 意义下的原根,那么 a 的任何正整数次幂对 n 取模的值都不相同,且能覆盖所有与 n 互质的数。 2. 为了求模 n 意义下的所有原根,我们需要先求出与 n 互质的数的个数 phi(n)。phi(n) 可以使用欧拉函数求出。 3. 然后,我们需要枚举模 n 意义下的所有数,判断它是否是原根。具体来说,对于每个 a,我们需要判断 a 的每个小于 phi(n) 的正整数次幂对 n 取模的值是否都不相同,且能覆盖所有与 n 互质的数。如果是,那么 a 就是模 n 意义下的原根。 4. 代码实现可以参考以下 Java 代码: ``` import java.util.*; public class Main { static int gcd(int a, int b) { return b == 0 ? a : gcd(b, a % b); } static int phi(int n) { int res = n; for (int i = 2; i * i <= n; i++) { if (n % i == 0) { res = res / i * (i - 1); while (n % i == 0) { n /= i; } } } if (n > 1) { res = res / n * (n - 1); } return res; } static int pow(int a, int b, int mod) { int res = 1; while (b > 0) { if ((b & 1) != 0) { res = res * a % mod; } a = a * a % mod; b >>= 1; } return res; } static boolean check(int a, int n, int phi) { for (int i = 1, j = pow(a, i, n); i <= phi; i++, j = j * a % n) { if (j == 1) { return false; } } return true; } public static void main(String[] args) { Scanner scanner = new Scanner(System.in); while (scanner.hasNext()) { int n = scanner.nextInt(); int phi = phi(n); List<Integer> ans = new ArrayList<>(); for (int i = 1; i < n; i++) { if (gcd(i, n) == 1 && check(i, n, phi)) { ans.add(i); } } Collections.sort(ans); for (int x : ans) { System.out.print(x + " "); } System.out.println(); } } } ``` 其中,gcd 函数用于求最大公约数,phi 函数用于求欧拉函数,pow 函数用于快速幂求模,check 函数用于判断一个数是否是原根。在主函数中,我们依次读入每个 n,求出 phi(n),然后枚举模 n 意义下的所有数,判断它是否是原根,将所有原根存入一个 List 中,最后排序输出即可。 希望我的回答能够帮到你,如果你有任何问题,欢迎随时提出。
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值