uva 10010(字符串)

题目:

Given a m by n grid of letters, ( $1 \leq m,n \leq 20$), and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid

input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The input begins with a pair of integers, m followed by n, $1 \leqm,n \leq 50$ in decimal notation on a single line. The next m lines contain n letters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another integer k appears on a line by itself ( $1 \leq k \leq 20$). The next k lines of input contain the list of words to search for, one word per line. These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).

output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found (1 represents the leftmost column in the grid, and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.

sample input

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert

sample output

2 5
2 3
1 2
7 8

题解:在一个都是字母的矩阵里寻找单词,八个方向去找,找到后输出第一个字母的位置,如果有多个输出最左边的对应单词的第一个字母的位置,多组测试样例之间有空行,但最后一组后没有。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

const int N = 60;
string grid[N];
string word;
int x, y, line, column;

int judge(int i, int j){
	int q, m = 1;
	int length = word.size();
	if(i - length + 1 >= 0 && j - length + 1 >= 0){
		for(q = 1; q < length; q++)
			if(word[q] == grid[j - m][i - m] || (word[q] - 32) == grid[j - m][i - m])
				m++;
			else
				break;
		if(q == length){
			x = j + 1;
			y = i + 1;
			return 1;
		}
	}
	if(i + length - 1 < column && j + length - 1 < line){
		m = 1;
		for(q = 1; q < length; q++)
			if(word[q] == grid[j + m][i + m] || (word[q] - 32) == grid[j + m][i + m])
				m++;
			else
				break;
		if(q == length){
			x = j + 1;
			y = i + 1;
			return 1;
		}
	}	
	if(i + length - 1 < column && j - length + 1 >= 0){
		m = 1;
		for(q = 1; q < length; q++)
			if(word[q] == grid[j - m][i + m] || (word[q] - 32) == grid[j - m][i + m])
				m++;
			else
				break;
		if(q == length){
			x = j + 1;
			y = i + 1;
			return 1;
		}
	}
	if(i - length + 1 >= 0 && j + length - 1< line){
		m = 1;
		for(q = 1; q < length; q++)
			if(word[q] == grid[j + m][i - m] || (word[q] - 32) == grid[j + m][i - m])
				m++;
			else
				break;
			if(q == length){
				x = j + 1;
				y = i + 1;
				return 1;
			}
	}
	if(i + length - 1 < column){
		m = 1;
	//	cout << "tuieort";
		for(q = 1; q < length; q++)
			if(word[q] == grid[j][i + m] || (word[q] - 32) == grid[j][i + m]){
				m++;
			//	cout << m;
			}
			else
				break;
			if(q == length){
				x = j + 1;
				y = i + 1;
				return 1;
			}
	}
	if(i - length + 1>= 0){
		m = 1;
		for(q = 1; q < length; q++)
			if(word[q] == grid[j][i - m] || (word[q] - 32) == grid[j][i - m])
				m++;
			else
				break;
			if(q == length){
				x = j + 1;
				y = i + 1;
				return 1;
			}
	}
	if(j + length - 1< line){
		m = 1;
		for(q = 1; q < length; q++)
			if(word[q] == grid[j + m][i] || (word[q] - 32) == grid[j + m][i])
				m++;
			else
				break;
			if(q == length){
				x = j + 1;
				y = i + 1;
				return 1;
			}
	}
	if(j - length + 1>= 0){
		m = 1;
		for(q = 1; q < length; q++)
			if(word[q] == grid[j - m][i] || (word[q] - 32) == grid[j - m][i])
				m++;
			else
				break;
			if(q == length){
				x = j + 1;
				y = i + 1;
				return 1;
			}
	}
	return 0;
}

void find(){
	int i, j, t;
	for(i = 0; i < column; i++)
		for(j = 0; j < line; j++){
			if(word[0] == grid[j][i] || (word[0] - 32) == grid[j][i]){
			//	cout << i << j;
				t = judge(i, j);
						if(t == 0)
					continue;
				else
					return;
			}
		}
}

int main(){
	int cases, i, j, k;
	cin >> cases;
	char c;
	getchar();
	while (cases--) {
		cin >> line >> column;
		getchar();
		for (i = 0; i < line; i++)
			getline(cin, grid[i]);
		for (i = 0; i < line; i++)
			for (j = 0; j < column; j++)
				if (grid[i][j] >= 97)
					grid[i][j] -= 32;
		cin >> k;
		getchar();
		while(k--) {
			word = "";
			getline(cin, word);
			find();
			cout << x << " " << y << endl;
		}
		if(cases > 0)
			cout << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值