HDU 1866 A + B forever! 有坑,注意题意!!!

A + B forever!

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1080    Accepted Submission(s): 232


Problem Description
As always, A + B is the necessary problem of this warming-up contest. But the patterns and contents are different from the previous ones. Now I come up with a new “A + B” problem for you, the top coders of HDU.
As we say, the addition defined between two rectangles is the sum of their area . And you just have to tell me the ultimate area if there are a few rectangles.
Isn’t it a piece of cake for you? Come on! Capture the bright “accepted” for yourself.
 

Input
There come a lot of cases. In each case, there is only a string in one line. There are four integers, such as “(x1,y1,x2,y2)”, describing the coordinates of the rectangle, with two brackets distinguishing other rectangle(s) from the string. There lies a plus symbol between every two rectangles. Blanks separating the integers and the interpunctions are added into the strings arbitrarily.The length of the string doesn’t exceed 500.
0<=x1,x2<=1000,0<=y1,y2<=1000.
 

Output
For each case, you just need to print the area for this “A+B” problem. The results will not exceed the limit of the 32-signed integer.
 

Sample Input
  
  
(1,1,2,2)+(3,3,4,4) (1,1,3,3)+(2,2,4,4)+(5,5,6,6)
 

Sample Output
  
  
2 8
 

Author
Wang Ye
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1867  1869  1211  1870  1753 

(1,/1,3,;; 3) / + ,/ (2, 2,4,4) +  , ( %6  ,!!6,5,5)
输出8
 

#include<stdio.h>
#include<string.h>
int m[1005][1005];
int max(int a,int b) { return a>b?a:b; }
int min(int a,int b) { return a<b?a:b; }
int main()
{
	char s[505],ch[505];
	int i,j,k,x1,y1,x2,y2,xmin,xmax,ymin,ymax,len,c,p;
	while(gets(s))
	{
		len=strlen(s);
		memset(m,0,sizeof(m)); memset(ch,0,sizeof(ch));
		c=k=p=0;
		for(i=0;i<len;i++)
		{
			if(s[i]>='0'&&s[i]<='9')
			{
				ch[k++]=s[i];
				if(!(s[i+1]>='0'&&s[i+1]<='9')) p++,ch[k++]=' ';
			}
			if(p==4)
			{
				ch[k++]='+';
				ch[k++]=' ';
				p=0;
			}
		}
		ch[k]='\0';
		len=strlen(ch);
		for(k=0;k<len;k++)
		{
			if(k==0 || ch[k-1]=='+')
			{
				sscanf(ch+k,"%d %d %d %d",&x1,&y1,&x2,&y2);
				xmin=min(x1,x2); xmax=max(x1,x2);
				ymin=min(y1,y2); ymax=max(y1,y2);
				for(i=xmin;i<xmax;i++)
					for(j=ymin;j<ymax;j++)
						if(!m[i][j]) {c++; m[i][j]=1;}
			}
		}
		printf("%d\n",c);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值