hdu5745(dp+bitset)

La Vie en rose

Time Limit: 7000/3500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3584    Accepted Submission(s): 940


Problem Description
Professor Zhang would like to solve the multiple pattern matching problem, but he only has only one pattern string  p=p1p2...pm. So, he wants to generate as many as possible pattern strings from  p using the following method:

1. select some indices  i1,i2,...,ik such that  1i1<i2<...<ik<|p| and  |ijij+1|>1 for all  1j<k.
2. swap  pij and  pij+1 for all  1jk.

Now, for a given a string  s=s1s2...sn, Professor Zhang wants to find all occurrences of all the generated patterns in  s.
 

Input
There are multiple test cases. The first line of input contains an integer  T, indicating the number of test cases. For each test case:

The first line contains two integers  n and  m  (1n105,1mmin{5000,n}) -- the length of  s and  p.

The second line contains the string  s and the third line contains the string  p. Both the strings consist of only lowercase English letters.
 

Output
For each test case, output a binary string of length  n. The  i-th character is "1" if and only if the substring  sisi+1...si+m1 is one of the generated patterns.
 

Sample Input
 
 
3 4 1 abac a 4 2 aaaa aa 9 3 abcbacacb abc
 

Sample Output
 
 
1010 1110 100100100
 

Author
zimpha

题意:给两个字符串 a 和 b ,b可以进行变换,规则是可以任意交换相邻两个字符的位置,但是不可以有交叉(例如3和4交换,5和6交换 互不影响,但是2和3,3和4就不可以)。求a中每一个位置能不能匹配b或b变换得到的子串。


思路:dp,dp[i]表示匹配模式串前i+1个的状况,其中dp[i][0],dp[i][1],dp[i][2]分别表示和前一个交换,不交换,和后一个交换的情况,采用bitset优化。

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<bitset>
using namespace std;
bitset<100005>dp[2][3],w[26];
char s[100005];
char t[5005];
int main()
{
    int tt;
    int n,m;
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d%d",&n,&m);
        scanf("%s%s",s,t);
        for(int i=0;i<26;i++)w[i].reset();
        for(int i=0;i<2;i++)
            for(int j=0;j<3;j++)
                dp[i][j].reset();
        for(int i=0;i<n;i++)
        {
            w[s[i]-'a'][i]=1;
        }
        dp[0][1]=w[t[0]-'a'];
        if(m>1)dp[0][2]=w[t[1]-'a'];
        int now = 0;
        for(int i=1;i<m;i++)
        {
            now^=1;
            dp[now][0]=(dp[now^1][2]<<1)&w[t[i-1]-'a'];
            dp[now][1]=((dp[now^1][1]|dp[now^1][0])<<1)&w[t[i]-'a'];
            if(i<m-1)
            {
                dp[now][2]=((dp[now^1][1]|dp[now^1][0])<<1)&w[t[i+1]-'a'];
            }
        }
        for(int i=0;i<n;i++)
        {
            if(dp[now][0][i+m-1]||dp[now][1][i+m-1])printf("1");
            else printf("0");
        }

        puts("");
    }
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值