HDU2648(简单hash)

Shopping

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2118    Accepted Submission(s): 706


Problem Description
Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called "memory". Now she wants to know the rank of this shop's price after the change of everyday.
 

Input
One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.
 

Output
Contains m lines ,In the ith line print a number of the shop "memory" 's rank after the ith day. We define the rank as :If there are t shops' price is higher than the "memory" , than its rank is t+1.
 

Sample Input
  
  
3 memory kfc wind 2 49 memory 49 kfc 48 wind 80 kfc 85 wind 83 memory
 

Sample Output
  
  
1 2
 

Author

dandelion




用map肯能会超时

#include <iostream>
#include <cstring>
#include <queue>
#include <cstdio>
#include <algorithm>
using namespace std;
#define LL unsigned int
#define M 10005
#define N 3131

struct shop{
    int p;
    char s[35];
}sp[M];
vector<shop> g[N];//用二位数组主要是为了防止地址冲突

bool cmp (shop a, shop b)
{
    return strcmp (a.s, b.s) < 0;
}

int BKDR_hash(char *str)
 {
    int seed = 131;
    int hash = 0;
      while (*str) hash = hash * seed + (*str++);
     return (hash & 0x7FFFFFFF) % N;//&0x7FFFFFFF这是为了防止负数产生
 }

int main()
{
    int  key;
    #ifdef xxz
    freopen("in.txt","r",stdin);
#endif
    int n, i, j, k, d, x, rank, ans;
    char s[35];
    while (~scanf ("%d", &n))
    {
        for (i = 0; i < N; i++)
            g[i].clear();
        for (i = 0; i < n; i++)
        {
            scanf ("%s", sp[i].s);
            sp[i].p = 0;
            key = BKDR_hash (sp[i].s);
            g[key].push_back (sp[i]);
        }
        scanf ("%d", &d);
        ans = 0;
        for (i = 0; i < d; i++)
        {
            for (j = 0; j < n; j++)
            {
                scanf ("%d %s", &x, s);
                key = BKDR_hash(s) % N;
                for (k = 0; k < g[key].size(); k++)
                {
                    if (strcmp (g[key][k].s, s) == 0)
                    {
                        g[key][k].p += x;
                        if (strcmp (s, "memory") == 0)
                            ans = g[key][k].p;
                        break;
                    }
                }
            }
            rank = 1;
            for (j = 0; j < N; j++)
                for (k = 0; k < g[j].size(); k++)
                    if (g[j][k].p > ans)
                        rank++;
            printf ("%d\n", rank);
        }
    }
    return 0;
}


  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值