POJ 1363 怎么又是水题

“水题”?真的好垃圾,这么水的题,竟然做了一两天。哎!我真是太菜了。。。。。。。

要加油了!奋斗


题目及代码如下:

D - 怎么又是水题
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. 

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes




题意:有n列火车,编号从1~n,进站的顺序从1~n,问能否按规定的顺序出站。


分析:简单的模拟题,就是模拟栈的操作。简单模拟一下即可,也可用库函数中写好的栈。





AC代码:

#include<stdio.h>
int a[1005];
int b[1005];
int just(int n)
{
    int j,top=0,k=1;
    for(j=1;j<=n;j++)
    {
        b[++top]=j;
        while(top && a[k]==b[top])
        {
            top--;
            k++;
        }
    }
    if(top)
        return 0;
    else
        return 1;
}

int main()
{
    int i,n,t=0;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        if(t)
            printf("\n");
        t++;
        while(scanf("%d",&a[1]))
        {
            if(a[1]==0)
                break;
            for(i=2;i<=n;i++)
                scanf("%d",&a[i]);
            if(just(n))
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值