POJ 2386 Lake Counting (dfs)

31 篇文章 0 订阅
Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19843 Accepted: 9980

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.  

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M  

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS:  

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source



题意:有一块园子,由于下雨,出现了水洼和干地,问图中有几块八连通(各个方向均为干地)的水洼。


心得:弱爆的英语啊,开始怎么读都没读懂,竟然把ponds想成了英镑大笑大笑大笑太恶心了,不可原谅...............后来读懂了,果断dfs啊,然后连样例都不对,我去,找了半天,最后发现是读取数据的时候我是用scanf(“%c”)一个字符一个字符的读,坑爹啊,刚开始也想不明白为什么这么做是错的,后来一试才知道,把换行也读了进去,唉。。。不忍直视啊,又暴漏了学渣的本质了.............用%s,或gets都可以,一行一行的读。还有就是大写的W,不是小写的,这还WA了两回...........


分析:从是W的位置开始向八个方向扩展状态,把扫过的点全变为“.”,这样dfs递归的的次数就是水洼的个数。





AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define INF 0x7fffffff
using namespace std;
const int maxn = 105;

char field[maxn][maxn];   //园子
int N,M;

void dfs(int x,int y)
{
    field[x][y]='.';       //将现在的位置替换为'.'

    for(int dx=-1;dx<=1;dx++)    //循环遍历8个方向
    {
        for(int dy=-1;dy<=1;dy++)
        {
          //向x方向移动dx,向y方向移动dy,移动的结果为(nx,ny)
            int nx = x + dx;
            int ny = y + dy;
          //判断(nx,ny)在不在园子内,以及是否有积水
            if(nx>=0 && nx<N && ny>=0 && ny<M && field[nx][ny] == 'W')    dfs(nx,ny);
        }
    }
    return;
}

void solve()
{
    int res=0;
    for(int i=0;i<N;i++)
    {
        for(int j=0;j<M;j++)
        {
            if(field[i][j]=='W')        //从有W位置开始dfs
            {
                dfs(i,j);
                res++;
            }
        }
    }
    printf("%d\n",res);
}

int main()
{
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        for(int i=0;i<N;i++)
//            for(int j=0;j<M;j++)
                scanf("%s",field[i]);
        solve();
    }
    return 0;
}


 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值