HDU 2399 GPA

23 篇文章 0 订阅

GPA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2502    Accepted Submission(s): 1469


Problem Description
Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.
 

Input
The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.
 

Output
Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.
 

Sample Input
  
  
A B C D F B F F C C A D C E F
 

Sample Output
  
  
2.00 1.83 Unknown letter grade in input
 

Author
2006Rocky Mountain Warmup
 

Source






解题思路:A,B,C,D,F各对应的分数为4,3,2,1,0,给出一行数据,每个字母用空格隔开,只能包含A,B,C,D,F和“ ”,若还有其他字符,则输出 ”Unknown letter grade in input“;若满足条件,则计算他们的平均值。




AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
 using namespace std;

char s[500];

 int main(){
 //	freopen("in.txt", "r", stdin);
 	while(gets(s)){
 		int len = strlen(s);
 		int cnt = 0;
 		int k = 0;
 		int flag = 1;
 		for(int i=0; i<len; i++){
 			if(s[i] == 'A') { cnt += 4; k++; }
 			else if(s[i] == 'B') { cnt += 3; k++; }
 			else if(s[i] == 'C') { cnt += 2; k++; }
 			else if(s[i] == 'D') { cnt += 1; k++; }
 			else if(s[i] == 'F') { cnt += 0; k++; }
 			else if(s[i] == ' ') continue;
 			else{
 				flag = 0;
 				break;
 			}
 		}
 		if(!flag) printf("Unknown letter grade in input\n");
 		else printf("%.2f\n", (float)cnt/k);
 	}
 	return 0;
 }




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值