UVa 10007 & hdu 1131 Count the Trees (卡特兰数)

27 篇文章 0 订阅
23 篇文章 0 订阅

Time Limit: 3000MS     Memory Limit: 0KB     64bit IO Format: %lld & %llu

Description

Download as PDF


  Count the Trees 

Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging.

Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers, and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactlyn different elements.

For example, given one element A, just one binary tree can be formed (usingA as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure.


\begin{picture}(400,90)(50,0)\put(115,62){A}\put(75,10){B}\put(120,60){\vecto......}}\put(365,62){B}\put(405,10){A}\put(370,60){\vector(1,-1){40}}\end{picture}

If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful.

Input 

The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 300 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed.

Output 

For each input case print the number of binary trees that can be built using the n elements, followed by a newline character.

Sample Input 

1
2
10
25
0

Sample Output 

1
4
60949324800
75414671852339208296275849248768000000


题意:给你n个点,问能够构成多少种不同的树。


解析:卡特兰数。




AC代码:

#include<cstdio>
#include<cstring>
#define SIZE 200
#define MAXN 302
#define BASE 10000

using namespace std;

int Canlan[MAXN][SIZE];
int temp[SIZE];

void A(int n)
{
    memcpy(temp, Canlan[n], sizeof(temp));
    int  e = 0;
    for(int fac = n; fac>0; --fac)
    {
        for(int i = SIZE-1, remain = 0; i>=0; --i)
        {
            e = temp[i] * fac + remain;
            temp[i] = e % BASE;
            remain = e / BASE;
        }
    }
    memcpy(Canlan[n], temp, sizeof(int)*SIZE);
}

void multiply(int elem)
{
    for(int i=SIZE-1, remain = 0; i >= 0; --i)
    {
        remain = temp[i] * elem + remain;
        temp[i] = remain % BASE;
        remain = remain / BASE;
    }
    return;
}

void divide(int elem)
{
    int i;
    for(i=0; i<SIZE && temp[i] == 0; i++);
    for(int remain = 0; i < SIZE; ++i)
    {
        remain += temp[i];
        temp[i] = remain / elem;
        remain = (remain % elem) * BASE;
    }
    return;
}

void Cantalan()
{
    memset(Canlan[1], 0, sizeof(int)*SIZE);
    Canlan[1][SIZE-1] = 1;
    for(int i=2; i<MAXN; ++i)
    {
        memcpy(temp, Canlan[i-1], sizeof(int)*SIZE);
        multiply(4*i-2);
        divide(i+1);
        memcpy(Canlan[i], temp, sizeof(int)*SIZE);
    }
    return;
}

int main()
{
    int n;
    Cantalan();
    for(int i=1; i<MAXN; ++i) A(i);
    while(scanf("%d", &n) != EOF && n)
    {
        int i;
        for(i=0; i<SIZE && Canlan[n][i] == 0; i++);
        printf("%d", Canlan[n][i]);
        if(i+1 == SIZE)
        {
            printf("\n");
            continue;
        }
        for(i=i+1; i<SIZE; ++i)
            printf("%04d", Canlan[n][i]);
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值